View Single Post
  #38  
Old 05-26-2017, 01:16 PM
crystalworks's Avatar
crystalworks crystalworks is offline
Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 3,917
crystalworks is on a distinguished road
Quote:
Originally Posted by phathom View Post
Ok, a little update. I checked and it is a variable displacement compressor, but it has a clutch. It's an internally regulated, aka by pressure and not by electronics. I also checked and contrary to what I believed, the clutch was not spinning when the ac was off, but it does engage and spin up each time with the ac on. It looked like it, but I put my hand down there and it does engage/disengage.
Still no cold AC though.
My aux fan does come on if I disconnect the pressure, but doesn't always come on when I have the ac on, only if it's working. Could this possibly be a bad pressure sensor for the fan?
I also read that some people have experienced if you rev the engine over 4k it kicks on and starts working. I'm in the car in my driveway as I'm typing this. Right now I reved the engine over 4k and almost instantly it went icy cold and the aux fan kicked on.
So what is going on?
Without the line pressures we are only guessing.

But I'd be apt to replace the compressor if all else seems good. Same with the expansion valve and receiver dryer. At the mileages these things are getting to I replace all sorts of stuff whether it's broken or not since parts (in at least some cases) will start to fail.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote

Sponsored Links