View Single Post
  #10  
Old 10-03-2018, 04:33 PM
Ricky Bobby's Avatar
Ricky Bobby Ricky Bobby is offline
Member
 
Join Date: Dec 2011
Location: Wake Forest, NC
Posts: 9,332
Ricky Bobby will become famous soon enough
In almost 8 years on this forum I've never seen the valve body leak under the car.


Your front bags are new, the rears are original we suspect. Your compressor is new. We suspect the level sensors are original?



Read the codes it is throwing in the EHC module as you said the fault is on the dash. Report back to us.


I've also seen the module itself go bad, the part # that it was revised to ends in #999 I believe, its not a cheap part.


You have 3 items to check out:
-Rear bags (however you said after you ran the calibration routine it started sagging in the front and the rear holds air, which makes me think its ok)

-Leveling sensors (and the "linkages" that hold them on the control arm, they are $6-7 but are a ball/socket joint that sometimes seize up) - one level sensor in front and one in rear
-EHC2 control module (if needing to replace its about $600-700 and needs to be coded)


IF the error is on the dash, read the codes and post them.
__________________
2003 X5 3.0i 5-Speed - Born on 9/18/2003
105k miles -Topaz Blue/Schwarz/Titan Int. Trim/EHCII/Sport
Proud 3-Pedal owner, UUC SS/AFE/4.8iS Exhaust/Sharked
2013 X5 35D (CEO's) - Born on 5/17/2013 -
68k miles - Alpine White/Cinnamon Brown/Premium Pkg, Sport Activity/Premium Pkg and Sound/20" Style 214/Running Boards

Reply With Quote

Sponsored Links