View Single Post
  #25  
Old 03-14-2020, 08:15 PM
crystalworks's Avatar
crystalworks crystalworks is offline
Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 4,503
crystalworks is on a distinguished road
Quote:
Originally Posted by BigLion View Post
This may be shutting the door when the horse has already bolted (hope you want to keep to air suspension rather than coils) - something I found weird when I assumed I had an air leak;
While the car was sitting with ignition off, one side was deflating, so of course I assumed I would have to replace the bags AGAIN... but one time I left it with the suspension in 'off-road' position... it DIDN'T deflate!

So I figured I had a screwy control module, not a leaky system. I reset all the heights with INPA and all is good now, parked in either position. I will eventually get round to replacing the module, but there's a ton of spending to do on it first
You know what? It inflated today. Only tried it because I left Carly in my wagon from yesterday switched on and it killed the battery. Figured wth and started the x5 to see if it would inflate since it was in front of the wagon so I could jump it. Started the truck... Nothing. Hit the switch to high ride height and it inflated.

Going to have to do some digging. Thank you for posting your experience.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote

Sponsored Links