View Single Post
  #77  
Old 03-29-2021, 08:06 PM
wpoll's Avatar
wpoll wpoll is offline
Member
 
Join Date: Sep 2015
Location: South Island, New Zealand
Posts: 3,784
wpoll will become famous soon enough
Great yarn, about a great journey.

Interesting to see the the 00BF error (IKI EEPROM error, coding faulty / incomplete) in the list - I have this one too. And I know where it came from.

A couple of years back I had a few spare days over the Christmas/Summer break. Always a precursor to bad stuff happening...

I had been wanting to goof with a little "light coding" and broke out my copy of NCS-Expert and NCS-Dummy (emphasis on the Dummy part).

Figured I'd start with something simple, like altering the coolant warning temp, which on my 3.0d is ridiculous at 125Deg.C. Seemed to work out ok.

So then I tackled (along with some others here) removing the speedo offset - the built in inaccuracy on the analogue speedo dial.

Not only did I fail to eliminate the offset - the flash attempt failed and I nearly bricked the IKE!!

Never did find out why - but I re-flashed the IKE with the backup of the firmware I had made before I started (thank goodness!!) and that flash worked. Everything returned to normal. Might have been bad checksums or shadow copies of the data I altered....

But ever since then I've had the 00BF error (IKI EEPROM error, coding faulty / incomplete). Doesn't seem to worry anything and I cannot seem to remove it.

I suspect flashing the IKE again might sort it but I haven't gone there!!
__________________
Wayne
2005 BMW X5 3.0d (b 02/05)
2001 BMW F650GS Dakar (b 06/01)
Reply With Quote

Sponsored Links