Thread: Misfire Misery
View Single Post
  #21  
Old 06-10-2021, 12:33 PM
Briansbummerbmw Briansbummerbmw is offline
Member
 
Join Date: Jun 2021
Location: Salt lake city
Posts: 14
Briansbummerbmw is on a distinguished road
More info that might help

I was thinking it might be a broken wire in harness is why I checked with noid light. But maybe more info a about the moment misfire started and some backstory. The car always had quite a bit of blow by out of oil filler hole but ran pretty good. I filled up an almost empty tank with gas, and was on the freeway for about 30 miles at about 70 miles when I felt a miss. Then in about a half mile later another and I was sure something was, so exited freeway and at red light was loping bad. I made it to work and took a chance on plugs ans coils in hopes that was it and could get back home. Problem still there but made it back. One other thing is that serpentine belt went out on freeway about 2000 miles earlier and I got the overheat light. I had just pulled off when the light came on. I let it cool down then drove about 5 min to autoparts and changed belt in parking lot. About 2 tablespoons of coolant had o overflowed around cap. It seemed fine after that but maybe the heat damaged something that just took a while to show up. Like bent or burnt valve. Maybe unrelated. The other thing is the first time I cleared to codes it had some pep and was feeling zippy or pretty good until the moment the check engine light on, so much so that my girlfriend thought I had fixed it. The moment check engine light came on it started crapping out again. I dont know if any of this is relevant. I'm starting to just lose my mind with frustration.
Reply With Quote

Sponsored Links