Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X3 (E83) Forum
Bimmer Tool Rental
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2019, 10:45 PM
Member
 
Join Date: Jun 2014
Location: Michigan
Posts: 7
jaskispyder is on a distinguished road
Oil filter whine noise

I was getting this noise: https://youtu.be/72OOBAYGNlA

It was the oil filter. I changed and noise came back 3 weeks later. Not as loud though. I used a Mann filter. I am going to try a Maule (SP) filter next. I am changing oil filter housing gasket as there was some wetness a year after replacing this gasket set. The bypass valve moves freely. I bought a new filter cap... Just in case that was having issues. Anyway. I will get it all changed and we will see if noise stays away. This is the first time I have had this noise after 5 years of ownership. N52 2007. Anyone else have this noise? How did you solve it?
Reply With Quote

Sponsored Links

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 03:34 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.