Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 03-23-2017, 02:31 PM
Member
 
Join Date: Jun 2015
Location: Southlake, Texas
Posts: 2,081
X53Jay4.8is is on a distinguished road
Quote:
Originally Posted by crystalworks View Post
Well everyone, we'll see how much that ad stands up to the hype they give it. I just got a code for thermostat on Tuesday. I reset it and it hasn't come back but I am going to do the WP and thermostat as PM. Went ahead and ordered their super thermostat. I think I am also going to do all the coolant hoses in the front. I recently did an expansion tank so I'll leave that alone I suppose, although it is a URO brand tank... ugh. Been working okay since last summer.

So, I'll be sure to update this thread with how amazing this colder thermostat is for us N62 owners.
Ooh get a OEM or BMW expansion tank to have on hand for when the URO blows this summer with the Texas intensified heat we will be having this summer. I get that the URO got you out of a sticky situation on a breakdown moment but that brand of component is a ticking time bomb.
Reply With Quote

Sponsored Links

  #12  
Old 03-23-2017, 02:36 PM
crystalworks's Avatar
Premier Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 3,204
crystalworks is on a distinguished road
Quote:
Originally Posted by X53Jay4.8is View Post
Ooh get a OEM or BMW expansion tank to have on hand for when the URO blows this summer with the Texas intensified heat we will be having this summer. I get that the URO got you out of a sticky situation on a breakdown moment but that brand of component is a ticking time bomb.
Agreed. It's in my FCP cart right now with all the hoses and stuff.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote
  #13  
Old 06-24-2018, 09:03 AM
Member
 
Join Date: Aug 2017
Location: Texas
Posts: 371
snik is on a distinguished road
What you got for us fam.
How's it running with the cooler t stat?


Sent from my iPhone using Tapatalk
__________________
Black on cream 04 4.8iS
Black on black 330i ZHP auto
Imola on black 01 M3
Reply With Quote
  #14  
Old 06-24-2018, 11:55 AM
crystalworks's Avatar
Premier Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 3,204
crystalworks is on a distinguished road
Quote:
Originally Posted by snik View Post
What you got for us fam.
How's it running with the cooler t stat?
I have been woefully remiss in working on the 4.8. Just finished some work to the wife's diesel and the 4.8 just keeps running well so with all the other things going on I keep pushing it til "next weekend."

Another member recently installed the Logic 7 thermostat and is happy with the results though. The thread should be on the first or second pages. With the south Texas heat here and fierce I need to push getting mine into the garage and replace all the stuff I have to go in it. Have like 2 large boxes of maintenance parts to go in.

I also need to update my build/maintenance log. There are never enough hours in the day.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote
  #15  
Old 06-24-2018, 12:47 PM
Member
 
Join Date: Aug 2017
Location: Texas
Posts: 371
snik is on a distinguished road
Quote:
Originally Posted by crystalworks View Post
I have been woefully remiss in working on the 4.8. Just finished some work to the wife's diesel and the 4.8 just keeps running well so with all the other things going on I keep pushing it til "next weekend."

Another member recently installed the Logic 7 thermostat and is happy with the results though. The thread should be on the first or second pages. With the south Texas heat here and fierce I need to push getting mine into the garage and replace all the stuff I have to go in it. Have like 2 large boxes of maintenance parts to go in.

I also need to update my build/maintenance log. There are never enough hours in the day.


Yeah. I saw that one. That's why I asked about it.
I'm thinking it would be great for the summers out here.
Thinking I want to order one.


Sent from my iPhone using Tapatalk
__________________
Black on cream 04 4.8iS
Black on black 330i ZHP auto
Imola on black 01 M3
Reply With Quote
  #16  
Old 02-06-2019, 04:31 PM
Member
 
Join Date: May 2018
Location: NYC
Posts: 825
mr_robot is on a distinguished road
Have you installed it yet? Did the code ever pop up again before you replaced it?

My 4.8iS just threw the code p0128 today but looking at the hidden menu on the cluster it was running 88-90*C and this was at stop and go traffic for about 30 min. Otherwise even after some hard pulls it remained constant +/- 5*C guess it was a soft fail or whatever.

So now just preparing myself for a new T-stat and thinking of doing the 90*C version.
__________________
2005 Imola 4.8iS

Last edited by mr_robot; 02-06-2019 at 07:08 PM.
Reply With Quote
  #17  
Old 02-06-2019, 07:19 PM
crystalworks's Avatar
Premier Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 3,204
crystalworks is on a distinguished road
Quote:
Originally Posted by mr_robot View Post
Have you installed it yet? Did the code ever pop up again before you replaced it?

My 4.8iS just threw the code p0128 today but looking at the hidden menu on the cluster it was running 88-90*C and this was at stop and go traffic for about 30 min. Otherwise even after some hard pulls it remained constant +/- 5*C guess it was a soft fail or whatever.

So now just preparing myself for a new T-stat and thinking of doing the 90*C version.

Nope... STILL have not installed it. T-stat code has never returned. There was someone here who did install it though I believe. Can't remember who.


I will be installing it soon(ish) though as my valve covers are leaking oil and the DS one is causing the alternator to be unhappy. So I'll be doing a major service at that time. Really looking forward to it... said no one ever.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote
  #18  
Old 02-06-2019, 07:49 PM
Member
 
Join Date: May 2018
Location: NYC
Posts: 825
mr_robot is on a distinguished road
Interesting that it never came back. Funny thing though my e70 with the n62 4.8 did the same. Cleared it once and never came back.
__________________
2005 Imola 4.8iS
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 12:43 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.