Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-06-2018, 04:19 AM
Member
 
Join Date: Oct 2018
Location: Tasmania
Posts: 7
simmo1708 is on a distinguished road
Rpm down then up under light acceleration

Hi Guys,

Ive joined this for a little advice.
I have a 2004 E53 X5 3.0D

I have a problem when i am doing between 60kph and 80kph ( this is where it does it the most) where the revs will drop for a second and then rise again. If i leave my foot on the accelerator it will do it a few times until the car changes speed.

Some times are worse than others with a bit of a vibration noise when the revs drop but nothing loud. If i accelerate out of it and speed up it goes away and is fine.

The car performs really well apart from this, no loss of power, fuel economy is fine. 160,000ks always serviced.
Nothing comes up on the scan tool.
Has anyone experienced this or have any recommendations??

**The trans was serviced 10,000ks or so ago and i was told its fine**

Thanks
Sam
Reply With Quote

Sponsored Links

  #2  
Old 10-06-2018, 05:29 AM
Member
 
Join Date: Jan 2011
Location: Blackburn UK
Posts: 323
RRPhil is on a distinguished road
Possibly the torque converter lock-up clutch? Do you have any diagnostics kit that can measure and record the engine, turbine & output speeds and the EDS 6 current, as this would confirm?



Phil
Reply With Quote
  #3  
Old 10-06-2018, 06:14 AM
Member
 
Join Date: Oct 2018
Location: Tasmania
Posts: 7
simmo1708 is on a distinguished road
Thanks Phil,
the only diagnostic tool i have is the scan tool. Looks like this

https://www.ebay.com.au/itm/OBD-OBD2...torefresh=true

Im not sure if its good enough to give than info?

Sam
Reply With Quote
  #4  
Old 10-06-2018, 12:31 PM
andrewwynn's Avatar
Premier Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 2,369
andrewwynn is on a distinguished road
Sounds like the TC is locking/unlocking when the TC locks the rpm will drop and rpm will tie directly to the speed.

Look through your scanner for real-time data for gears, lockup or output speed you can confirm. You can also tell from speed/rpm.

When TC locks up you'll lose all acceleration and any throttle application should unlock with an immediate bump in RPM before any speed increase.

Why the TC would be switching in/out of lock without throttle sounds like your quest.


Sent from my iPhone using Tapatalk Pro
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #5  
Old 10-06-2018, 04:04 PM
jopecasa's Avatar
Premier Member
 
Join Date: Mar 2015
Location: Sydney Australia
Posts: 481
jopecasa is on a distinguished road
Quote:
Originally Posted by RRPhil View Post
Possibly the torque converter lock-up clutch? Do you have any diagnostics kit that can measure and record the engine, turbine & output speeds and the EDS 6 current, as this would confirm?

Phil

Thanks for chiming-in here RRPhil.

Looking at the chart, the RR TC is always coupled on 3rd gear regardlesss of speed (0-50).....at granny style driving?

I have been wanting to understand my Throttle position behaviour relative to transmission gear position.

Can you also provide info in Sport mode and how the 5th and 6th gear engages.

Cheers!
__________________
01 E39 530i - SOLD !
05 E53 4.8is


Pics of Bianca (E39) and Betsy (E53)
Reply With Quote
  #6  
Old 10-07-2018, 03:31 AM
andrewwynn's Avatar
Premier Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 2,369
andrewwynn is on a distinguished road
I took a video last night when driving about 80-90 kph and gently accelerating then using a slight burst of acceleration to break the TC lock then holding the new throttle position to let the TC the lock and record on video the drop in RPM when that happens.

If something changed in the TC behavior that's of concern. Also there is a fairly good chance of the throttle position sensor soft-failing. It has two parallel potentiometers for redundance and that can cause some weird throttle behavior when one side fails but not total failure open or short. (Think noisy volume control on old am radio)

Look through your scanner live view options. I can watch all aspects of the transmission real time: input/output rpm, tc lock etc. Also the two throttle sensor values to confirm they are both operating properly. If yours can't do this, get a better scanner.


Sent from my iPhone using Tapatalk Pro
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #7  
Old 10-07-2018, 02:50 PM
Member
 
Join Date: Jan 2011
Location: Blackburn UK
Posts: 323
RRPhil is on a distinguished road
Quote:
Originally Posted by jopecasa View Post
Looking at the chart, the RR TC is always coupled on 3rd gear regardlesss of speed (0-50).....at granny style driving?
Hereís a heavy throttle acceleration run for the 6HP26 in a Range Rover and you can see that the converter is open in 1st gear, operates in controlled slip mode in 2nd gear, and then is locked solid from 3rd gear upwards.



The converter lock-up behaviour/timing will, most likely, be defined by the calibrators working in the control department of the car company, and not by ZF, so the LUC timing in the L322 may not be the same as an E53. I donít have any measurements for the E53, Iím afraid.

Phil
Reply With Quote
  #8  
Old 10-10-2018, 03:48 PM
jopecasa's Avatar
Premier Member
 
Join Date: Mar 2015
Location: Sydney Australia
Posts: 481
jopecasa is on a distinguished road
Awesome info RRPhil!

I'll investigate further my issues on why 4th gear engages and shifts so early on either light and hard acceleration.

Other than that...all is well on my SAV.

cheers!
__________________
01 E39 530i - SOLD !
05 E53 4.8is


Pics of Bianca (E39) and Betsy (E53)
Reply With Quote
  #9  
Old 10-10-2018, 06:32 PM
andrewwynn's Avatar
Premier Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 2,369
andrewwynn is on a distinguished road
Maybe adaptations reset? I forgot if you did you did any service that would make sense to do that. If I had any odd shifting I'd probably do that


Sent from my iPhone using Tapatalk Pro
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #10  
Old 10-11-2018, 02:37 AM
jopecasa's Avatar
Premier Member
 
Join Date: Mar 2015
Location: Sydney Australia
Posts: 481
jopecasa is on a distinguished road
andrewwynn,

Have done all my transmission servicing (pan,filter, guibo and the plastic servo) and rear diff oil change.

I'm just OCD perhaps.

Reset adaptation via INPA and tested and activated individual solenoid valves on mechatronics....found no issues.

Next .....Throttle pedal signal to DME.....


To the OP......not to hijack your thread.
__________________
01 E39 530i - SOLD !
05 E53 4.8is


Pics of Bianca (E39) and Betsy (E53)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 01:46 AM.
vBulletin, Copyright 2018, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.