Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #21  
Old 12-16-2019, 03:21 AM
Member
 
Join Date: Oct 2018
Location: mackay qld
Posts: 39
Gixman05 is on a distinguished road
Smile

fitted an after market boost converter solenoid from ebay for around $50aud. immediately was different to the oem one that was removed. it would randomly open the vgt vanes at idle,mid throttle and pretty much anywhere anytime and sooted like crazy from the exhaust because it was not making boost correctly. I contacted the seller with not much luck. I left it in there as I needed the car operational for work. I ordered an oem one from ebay as well for around $198aud. immediately worked as it should from the get go. it is a little lower on boost than the previous one at around peak 21psi and settles at 18psi but hopefully just needs a little adjustment of the actuator arm. but finally problem solved. the diaphragm in the original one had a slight leak and wouldn't hold vacuum for extended periods of time. Thx for everyones input and time to help me sort this one out.

Cheers Russ
Reply With Quote

Sponsored Links

  #22  
Old 12-16-2019, 03:09 PM
wpoll's Avatar
Member
 
Join Date: Sep 2015
Location: South Island, New Zealand
Posts: 3,368
wpoll will become famous soon enough
Quote:
Originally Posted by Gixman05 View Post
fitted an after market boost converter solenoid from ebay for around $50aud. immediately was different to the oem one that was removed. it would randomly open the vgt vanes at idle,mid throttle and pretty much anywhere anytime and sooted like crazy from the exhaust because it was not making boost correctly. I contacted the seller with not much luck. I left it in there as I needed the car operational for work. I ordered an oem one from ebay as well for around $198aud. immediately worked as it should from the get go. it is a little lower on boost than the previous one at around peak 21psi and settles at 18psi but hopefully just needs a little adjustment of the actuator arm. but finally problem solved. the diaphragm in the original one had a slight leak and wouldn't hold vacuum for extended periods of time. Thx for everyones input and time to help me sort this one out.

Cheers Russ
Thanks for the follow-up post, Russ. Your contribution to the body of knowledge here is very welcome!!

I'm interested to hear that the actuator diaphragm was the actual fault - as I suggested in post#9, a vacuum leak-down test of the control would show this up, so at least I wasn't totally off-base there.
__________________
Wayne
2005 BMW X5 3.0d (b 02/05)
2001 BMW F650GS Dakar (b 06/01)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 01:10 AM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.