Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-07-2022, 05:31 PM
ewebby's Avatar
Member
 
Join Date: Jul 2005
Location: Phoenix
Posts: 134
ewebby is on a distinguished road
Question Stumble from stop light under mid to heavy throttle

2001 X5 3.0 from a start, stumbles like it is not getting power, from stop only. More so when fully warmed up.
Changed intake cam sensor. Exhaust was done about 30k ago.
DISA checked and fine. Idle control valve was cleaned about 20k ago.

Could be:
  • Throttle position sensor,
  • crankshaft sensor,
  • trans solenoid,
  • wheel speed sensor, or
  • air leak
  • transfer case gear?

No codes. 260k miles
I do need to replace my drivers side Fuel Tank Sending Unit as after a fill up the fuel level did not come back. It came back after a week full of gas though.
__________________
Kevin
2001 X5 3.0i
Phoenix, AZ
Reply With Quote

Sponsored Links

  #2  
Old 04-07-2022, 07:05 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 9,753
andrewwynn will become famous soon enough
How old is the fuel pump? Feels like fuel pump
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)
Reply With Quote
  #3  
Old 04-07-2022, 07:13 PM
Member
 
Join Date: Jun 2021
Location: Austin, TX
Posts: 686
X5chemist is on a distinguished road
How old are the plugs? Has the VANOS ever been rebuilt?
__________________
'06 X5 3.0i - bought @143,123 miles (12/26/20)
Reply With Quote
  #4  
Old 04-07-2022, 07:20 PM
ewebby's Avatar
Member
 
Join Date: Jul 2005
Location: Phoenix
Posts: 134
ewebby is on a distinguished road
vanos rebuilt about 60k ago - full rebuild
__________________
Kevin
2001 X5 3.0i
Phoenix, AZ
Reply With Quote
  #5  
Old 04-07-2022, 07:21 PM
ewebby's Avatar
Member
 
Join Date: Jul 2005
Location: Phoenix
Posts: 134
ewebby is on a distinguished road
Quote:
Originally Posted by andrewwynn View Post
How old is the fuel pump? Feels like fuel pump
Fuel pump replaced about 30k miles ago
__________________
Kevin
2001 X5 3.0i
Phoenix, AZ
Reply With Quote
  #6  
Old 04-07-2022, 07:21 PM
ewebby's Avatar
Member
 
Join Date: Jul 2005
Location: Phoenix
Posts: 134
ewebby is on a distinguished road
perhaps the one side of tank is not sending fuel since the fuel level sensor seems bad
__________________
Kevin
2001 X5 3.0i
Phoenix, AZ
Reply With Quote
  #7  
Old 04-07-2022, 07:42 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 9,753
andrewwynn will become famous soon enough
The float for level doesn't interfere with fuel delivery, however if you don't know how much fuel, add enough to know you have 1/2 tank and test.

Siphon jet problems occur close to 1/3 to 1/4 tank and could cause a delivery problem but usually it isn't power problems it's fuel starvation stall.

When fuel pump is near end of life, the FPR will hide a weak pump and symptoms show up under moderate to heavy demand.
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)
Reply With Quote
  #8  
Old 04-07-2022, 07:50 PM
ewebby's Avatar
Member
 
Join Date: Jul 2005
Location: Phoenix
Posts: 134
ewebby is on a distinguished road
i have 1/3 tank, only and issue from stop and med to hard acceleration for about 2 seconds until it gets going. RPM / Torque related I am thinking.
throttle position sensor
exhaust cam sensor
crankshaft sensor
oxygen sensors
smoke test?
Fuel Tank Sending Unit
Fuel pump
wheel speed sensor
clean maf
__________________
Kevin
2001 X5 3.0i
Phoenix, AZ
Reply With Quote
  #9  
Old 04-07-2022, 08:25 PM
ewebby's Avatar
Member
 
Join Date: Jul 2005
Location: Phoenix
Posts: 134
ewebby is on a distinguished road
Tested in neutral, misses when tapping throttle, goes away on after a second . No cel. Original coils. Bad spark plug? Only 23k on plugs. MAF or TPS is my guess. I have Autel MaxiDiag MD808 Pro perhaps I can run live data
__________________
Kevin
2001 X5 3.0i
Phoenix, AZ
Reply With Quote
  #10  
Old 04-07-2022, 09:21 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 9,753
andrewwynn will become famous soon enough
Stumble from stop light under mid to heavy throttle

Track real time TPS values can your scanner graph? Also pedal sensors.

Then: fuel pressure while hitting throttle. It should be dead flat no waver.
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)

Last edited by andrewwynn; 04-07-2022 at 10:30 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 03:06 AM.
vBulletin, Copyright 2022, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.