Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Bimmer Tool Rental
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-17-2011, 06:14 PM
Member
 
Join Date: Aug 2007
Location: San Diego
Posts: 19
xfizzle is on a distinguished road
One more "Self Leveling Air Suspension Inactive" question

So, I have the error on my display. My X5 is slammed in the back and rides like a hoopty. I don't hear the compressor going when I get in the car. Anyone with experience know of a quick diagnostic to figure out if it the compressor or the module? Or is it even something else? Thanks!
Reply With Quote

Sponsored Links

  #2  
Old 10-17-2011, 07:29 PM
Member
 
Join Date: Nov 2008
Location: Bluffton, SC
Posts: 2
miles is on a distinguished road
answer

Although this isnt a permanent fix, it has worked for years on my X5. Simply replace the fuse in the right rear pannel in the cargo area. I took mine to the dealership with the same fault and thats all they did. Mechanic suggested doing it until the pump failed. 25 cent fuse vs a 1200 dollar pump. easy decision!!
Reply With Quote
  #3  
Old 10-17-2011, 07:44 PM
Member
 
Join Date: Aug 2007
Location: San Diego
Posts: 19
xfizzle is on a distinguished road
Dude! That did it! I didn't even think to check the fuse. I guess I always just assume failure of a part and don't even check the fuse. I was just about to start ripping apart the air suspension components and start trouble shooting each part which I would have never gotten right since the fuse was blown! Thanks so much.
Reply With Quote
  #4  
Old 10-17-2011, 09:30 PM
Member
 
Join Date: Nov 2008
Location: Bluffton, SC
Posts: 2
miles is on a distinguished road
Glad it worked for you. I had to replace my fuse a few more times after the dealer did it and then it just stopped. I guess just one of those weird BMW electrical things.
Reply With Quote
  #5  
Old 10-17-2011, 10:25 PM
pezho405's Avatar
Member
 
Join Date: Nov 2010
Location: Charlotte,NC/Воронеж,Росси&#
Posts: 1,276
pezho405 is on a distinguished road
Is it ok to ride without a fuse for a couple days so the motor doesnt burn up pumping air into a broken spring??
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 11:44 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.