Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E70) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 05-04-2023, 05:36 PM
SF2000x5's Avatar
Member
 
Join Date: Nov 2011
Location: San Francisco CA
Posts: 245
SF2000x5 is on a distinguished road
Similar issue on my 07 3.0si. Didn’t pass smog due to po420 and 430. I was going to install defoulers but there isn’t much room around the bank 2 sensors.

Going to try Cataclean to clean the cats to get it to pass smog test. It seems to be driving fine except I do smell a hint of oil being burned after a longer drive. No smoke or smell like a failed valve cover gasket though.

I’m doubting new sensors would fix my issue. I also had some oil on the connectors but the o rings kept the connection dry.

What tools did you use to get the bank 2 sensor that screws in vertically? I’d say it’s the left exhaust pipe.
__________________
e70 - purchased 6/2018
e36 - wouldn't pass smog at 190k 2016
e53 - transmission blew at 225k 2012
e30 - sold as it was a little slow for a DD and burning oil at 220k 2011
Reply With Quote

Sponsored Links

  #12  
Old 05-05-2023, 02:57 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 10,730
andrewwynn will become famous soon enough
I use a typical crow foot 22mm socket but I put the socket extension in "from the wrong side" and turn righty-loosey.

I used two part 90° defouler but can't seem to find them anymore for sale.

Remove the harmonic isolator that's in the way when working on post cat O₂.

I will pre-twist the cable backwards so I can turn in the sensor ending up no twists.
__________________
2011 E70 • N55 (me)
2012 E70 • N63 (wife)
Reply With Quote
  #13  
Old 05-05-2023, 03:57 PM
SF2000x5's Avatar
Member
 
Join Date: Nov 2011
Location: San Francisco CA
Posts: 245
SF2000x5 is on a distinguished road
Quote:
Originally Posted by andrewwynn View Post
I use a typical crow foot 22mm socket but I put the socket extension in "from the wrong side" and turn righty-loosey.

I used two part 90° defouler but can't seem to find them anymore for sale.

Remove the harmonic isolator that's in the way when working on post cat O₂.

I will pre-twist the cable backwards so I can turn in the sensor ending up no twists.
I might have to pickup crow foot and some angled defoulers online.

Thanks
__________________
e70 - purchased 6/2018
e36 - wouldn't pass smog at 190k 2016
e53 - transmission blew at 225k 2012
e30 - sold as it was a little slow for a DD and burning oil at 220k 2011
Reply With Quote
  #14  
Old 05-05-2023, 04:30 PM
ard ard is offline
Member
 
Join Date: Mar 2006
Location: Sierra Foothills, California
Posts: 6,724
ard is on a distinguished road
FWIW...dont automatically think it needs a full "Overhaul"


Just removing the solenoids and flushing them with spray solvent will do utter wonders.... aint a big deal.
Reply With Quote
  #15  
Old 05-05-2023, 07:09 PM
SF2000x5's Avatar
Member
 
Join Date: Nov 2011
Location: San Francisco CA
Posts: 245
SF2000x5 is on a distinguished road
Put in come cataclean in the tank and drove it for about 20 mins and the catalyst passes without a code. Previously, po420 and po430 was in pending status, now only po430 is pending.

Catalcean smelled like rubbing alcohol. Didn’t think it would work but I guess it cleaned the cats and/or 02 sensors.
__________________
e70 - purchased 6/2018
e36 - wouldn't pass smog at 190k 2016
e53 - transmission blew at 225k 2012
e30 - sold as it was a little slow for a DD and burning oil at 220k 2011

Last edited by SF2000x5; 05-05-2023 at 11:57 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 01:33 AM.
vBulletin, Copyright 2024, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.