Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E70) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-11-2014, 10:07 PM
Member
 
Join Date: Aug 2012
Location: NYC
Posts: 124
euge is on a distinguished road
2008 4.8i Fluctuating RPM / Power loss

92k on the clock. P0121, P0120, P0221 codes pop up.



checked the throttle body and cleaned it out, looked pretty clean before but I did it anyway. a buddy of mine thinks it's the harness or a sensor. i've linked a video below, anyway I can fix this myself?

View My Video
Reply With Quote

Sponsored Links

  #2  
Old 07-12-2014, 10:19 AM
ART-qitec's Avatar
Member
 
Join Date: Aug 2013
Location: Miami, FL
Posts: 103
ART-qitec is on a distinguished road
Quote:
Originally Posted by euge View Post
92k on the clock. P0121, P0120, P0221 codes pop up.



checked the throttle body and cleaned it out, looked pretty clean before but I did it anyway. a buddy of mine thinks it's the harness or a sensor. i've linked a video below, anyway I can fix this myself?

View My Video
Hello, are you getting a DBC MALFUNCTION on idrive as well?
Reply With Quote
  #3  
Old 07-12-2014, 11:56 AM
Member
 
Join Date: Aug 2012
Location: NYC
Posts: 124
euge is on a distinguished road
Quote:
Originally Posted by ART-qitec View Post
Hello, are you getting a DBC MALFUNCTION on idrive as well?
Yep
Reply With Quote
  #4  
Old 07-12-2014, 12:37 PM
ART-qitec's Avatar
Member
 
Join Date: Aug 2013
Location: Miami, FL
Posts: 103
ART-qitec is on a distinguished road
Quote:
Originally Posted by euge View Post
Yep
Yep it ended up being the throttle body harness for me. It's a quick 30 minute job if you know what you're doing. I would take some pictures to help you out but my X5 is currently in the shop getting fixed (hit a curb to avoid hitting a dog). Let me know if you had any questions.
Reply With Quote
  #5  
Old 07-12-2014, 01:01 PM
Member
 
Join Date: Aug 2012
Location: NYC
Posts: 124
euge is on a distinguished road
Quote:
Originally Posted by ART-qitec View Post
Yep it ended up being the throttle body harness for me. It's a quick 30 minute job if you know what you're doing. I would take some pictures to help you out but my X5 is currently in the shop getting fixed (hit a curb to avoid hitting a dog). Let me know if you had any questions.
Did you replace it?
Reply With Quote
  #6  
Old 07-12-2014, 03:45 PM
ART-qitec's Avatar
Member
 
Join Date: Aug 2013
Location: Miami, FL
Posts: 103
ART-qitec is on a distinguished road
Quote:
Originally Posted by euge View Post
Did you replace it?
Yeah I cut and spliced a new harness.
Reply With Quote
  #7  
Old 07-12-2014, 03:59 PM
Member
 
Join Date: Aug 2012
Location: NYC
Posts: 124
euge is on a distinguished road
Also got a cruise control malfunction error. The car just keeps jerking at stops.
Reply With Quote
  #8  
Old 07-12-2014, 04:48 PM
ART-qitec's Avatar
Member
 
Join Date: Aug 2013
Location: Miami, FL
Posts: 103
ART-qitec is on a distinguished road
Quote:
Originally Posted by euge View Post
Also got a cruise control malfunction error. The car just keeps jerking at stops.
Yeah , my X5 had the exact same symptoms as yours does now. It keeps jerking forward correct? You have to keep hard on the brake pedal to prevent it from moving forward? If so, I'm 99% certain you need to splice a new harness.
Reply With Quote
  #9  
Old 07-12-2014, 05:36 PM
Member
 
Join Date: Aug 2012
Location: NYC
Posts: 124
euge is on a distinguished road
Quote:
Originally Posted by ART-qitec View Post
Yeah , my X5 had the exact same symptoms as yours does now. It keeps jerking forward correct? You have to keep hard on the brake pedal to prevent it from moving forward? If so, I'm 99% certain you need to splice a new harness.
That is exactly what happens! do you have a part number for the harness?
Reply With Quote
  #10  
Old 07-12-2014, 10:08 PM
Member
 
Join Date: Dec 2008
Location: NJ
Posts: 24
aclockwrk is on a distinguished road
I had the exact same thing happen about 2 years ago and again today. I unplugged and reseted the plug that goe to the throttle body and then cleared the codes with a Bavarian technic cable so far so good. When it happened today it looked loose.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 12:42 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.