Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Search Forums
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Showing results 1 to 25 of 77
Search took 0.41 seconds.
Search: Posts Made By: mendes9
Forum: X5 (E53) Forum 10-07-2018, 01:21 AM
Replies: 0
Views: 196
Posted By mendes9
Daytime running lights H1 LED bulb recommendations?

I tried searching but didn't find much. Looking to replace my amber DRL bulbs with something white. I see the sylvania's H1, but wonder if anyone has an LED recommendations that work well, and will...
Forum: X5 (E53) Forum 10-07-2018, 01:04 AM
Replies: 11
Views: 956
Posted By mendes9
Thank you, I was very very close to ordering the...

Thank you, I was very very close to ordering the Foxwell NT520.
Forum: X5 (E53) Forum 10-05-2018, 09:38 AM
Replies: 11
Views: 956
Posted By mendes9
2006 X5 E53 ABS brak bleed INPA software no good, ISTA works.

I thought maybe I would post my experience, and perhaps save someone some time, or someone can tell me what I did wrong with INPA or confirm my model should work with ABS BLEED procedure with INPA.
...
Forum: X5 (E53) Forum 10-04-2018, 03:45 PM
Replies: 9
Views: 912
Posted By mendes9
Did you ever find a solution? Same exact problem....

Did you ever find a solution? Same exact problem. 3.0 2006
Forum: X5 (E53) Forum 10-01-2018, 09:27 AM
Replies: 6
Views: 575
Posted By mendes9
Thank you, after some further reading that what...

Thank you, after some further reading that what appears to be the issue. I will update the thread with results.
Forum: X5 (E53) Forum 09-30-2018, 08:31 PM
Replies: 6
Views: 575
Posted By mendes9
2006 x5 brake pedal travel goes low even after bleeding.

Hi all, a couple days ago "low brake fluid" message came up and noticed that it was a little low, and then pedal went lower than usual. I put in additional fluid pumped brakes but pedal still...
Forum: X5 (E53) Forum 05-26-2018, 09:06 AM
Replies: 12
Views: 2,662
Posted By mendes9
Thanks Wayne I was going to play with this today,...

Thanks Wayne I was going to play with this today, but I'm at a loss. Yes, the rear wiper and front wipers work fine. But again, no power to either of the 3 pumps on the tank under the hood. Checking...
Forum: X5 (E53) Forum 05-15-2018, 08:32 PM
Replies: 12
Views: 2,662
Posted By mendes9
Thanks, the first diagram is clear the 2nd i cant...

Thanks, the first diagram is clear the 2nd i cant see how you can tell those fuses are connected to the pump motors.
Forum: X5 (E53) Forum 05-15-2018, 07:53 AM
Replies: 12
Views: 2,662
Posted By mendes9
Thanks it's the 3.0 ... thanks for the link! Hard...

Thanks it's the 3.0 ... thanks for the link! Hard to tell from the diagram it looks like K11 drives all power to pumps and wipers.
Forum: X5 (E53) Forum 05-14-2018, 09:12 PM
Replies: 12
Views: 2,662
Posted By mendes9
2006 E53 X5 Windshield washer no power to pumps

Hello,

My windshield washers stopped working. Upon diagnosing I'm not getting any power to any of the 3 washer pumps, even with the car turned on. I found the fuse under the glove box which was...
Forum: X5 (E53) Forum 01-29-2018, 09:36 PM
Replies: 1
Views: 387
Posted By mendes9
Are fenders specific to 00-03 and 04-06 years or the same?

Looking for a fender due to an accident, are fenders the same from 00 thru 06? Or specific to 00-03 and 04-06? thanks
Forum: X5 (E53) Forum 05-14-2017, 01:14 PM
Replies: 15
Views: 8,209
Posted By mendes9
Update: found that the driver side drain tube was...

Update: found that the driver side drain tube was clogged, I put my air compressor novle on the hose located inside the pillar, and sprayed air up towards the roof, bam stuff came out and now it...
Forum: X5 (E53) Forum 05-14-2017, 10:10 AM
Replies: 15
Views: 8,209
Posted By mendes9
Same problem, I took off the a pillar covers both...

Same problem, I took off the a pillar covers both sides were some what kinked, but I don't think that's the problem. I got my compressed air gun and sprayed air into the hole. Then I opened my pano...
Forum: X5 (E53) Forum 05-27-2016, 12:52 AM
Replies: 4
Views: 1,195
Posted By mendes9
Thank you. I read others just getting it out...

Thank you. I read others just getting it out through the bottom without having to remove the bumper.
Forum: X5 (E53) Forum 03-20-2016, 11:04 AM
Replies: 8
Views: 2,306
Posted By mendes9
Dam, you know that's what I thought, as it's...

Dam, you know that's what I thought, as it's impossible to fit as is. I looked at it carefully but it looked like it was part of the housing. I didn't try a c clamp but I did thread the bolt and...
Forum: X5 (E53) Forum 03-19-2016, 04:53 PM
Replies: 8
Views: 2,306
Posted By mendes9
Joshdub, no that wasn't the issue the holes for...

Joshdub, no that wasn't the issue the holes for both the alternator housing, and the engine housing were both fine. I'm telling you I don't know how this was in there.

I took my 4" whell...
Forum: X5 (E53) Forum 03-19-2016, 01:45 PM
Replies: 8
Views: 2,306
Posted By mendes9
Can't get lower bolt on alternator back on, doesn't fit.

Is there a trick to get the lower bolt on the alternator. It simply won't slip over the housing, no matter how neatly line it up. Tried giving it some heat, banged on it with a hammer a little...
Forum: X5 (E53) Forum 03-18-2016, 08:32 PM
Replies: 2
Views: 370
Posted By mendes9
Is there a secret to replacing the cold air duct hose for alternator?

Hello,

Today, I went about fixing 2 issues on my 06 x5 3.0 104K miles. The expansion tank had a hairline crack and I was loosing coolant, and I had an oil leak I believe coming from the oil...
Forum: X5 (E53) Forum 05-30-2015, 06:15 PM
Replies: 46
Views: 17,340
Posted By mendes9
Did this today.. nice write up, however, there...

Did this today.. nice write up, however, there are more screws that need to be removed at least in my case. What a pain, some repairs are so easy on this car and others so un-necessarily difficult.
Forum: X5 (E53) Forum 10-24-2014, 10:03 AM
Replies: 31
Views: 5,781
Posted By mendes9
Update: Car started perfectly.. today no...

Update:
Car started perfectly.. today no issues. And that slight hesitation upon initial acceleration that I noticed after replacing the fuel pump is now completely gone, throttle response is...
Forum: X5 (E53) Forum 10-23-2014, 03:09 PM
Replies: 31
Views: 5,781
Posted By mendes9
So yesterday after replacing the fuel pump all...

So yesterday after replacing the fuel pump all was well as noted. Today I go to start the car and it starts but shortly dies, I started the car a couple times, in order to keep it running I had to...
Forum: X5 (E53) Forum 10-22-2014, 04:11 PM
Replies: 31
Views: 5,781
Posted By mendes9
Update: SUCCESS!! :thumbup: After replacing...

Update: SUCCESS!! :thumbup:

After replacing the fuel pump the X is up and running again. A few notes, when replacing the fuel pump that may help others if you have never done it before. After you...
Forum: X5 (E53) Forum 10-18-2014, 03:45 PM
Replies: 31
Views: 5,781
Posted By mendes9
Ok I'm trying to determine if fuel pump is...

Ok I'm trying to determine if fuel pump is getting power and I need some help. OK, when I put my volt meter on the fuel pump electrical connector, I'm only getting 12v on the small black with red...
Forum: X5 (E53) Forum 10-18-2014, 01:09 PM
Replies: 31
Views: 5,781
Posted By mendes9
Ok so I replaced the MAF no change as expected. ...

Ok so I replaced the MAF no change as expected. Now I borrowed the a fuel pressure gauge from autozone. Bingo.. no pressure. I removed the back seat and had someone turn the key and I hear gurgle...
Forum: X5 (E53) Forum 10-17-2014, 09:26 PM
Replies: 31
Views: 5,781
Posted By mendes9
Ok so today I replaced the DISA valve (what a...

Ok so today I replaced the DISA valve (what a waste of almost $300 due to breaking the old one), and I also installed new air intake boot. As expected it didn't make a difference. Plan of action for...
Showing results 1 to 25 of 77

 
Forum Jump



All times are GMT -4. The time now is 04:11 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.