Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Search Forums
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Showing results 1 to 4 of 4
Search took 0.13 seconds.
Search: Posts Made By: 04X3
Forum: X3 (E83) Forum 03-28-2013, 10:24 PM
Replies: 13
Views: 3,004
Posted By 04X3
I believe the problem lies in the plastic...

I believe the problem lies in the plastic impeller of the pump. In cold temps. The impeller may try to propel frozen or half frozen liquid. Increased resistance breaks impeller off, meaning we hear...
Forum: X3 (E83) Forum 03-28-2013, 10:22 PM
Replies: 13
Views: 3,004
Posted By 04X3
It's not that important IMHO. Just disconnect the...

It's not that important IMHO. Just disconnect the power to the pump.
Forum: X3 (E83) Forum 03-28-2013, 10:21 PM
Replies: 13
Views: 3,004
Posted By 04X3
Unresolved, dealer quoted me 160 for new pump! I...

Unresolved, dealer quoted me 160 for new pump! I said no thank you.
Forum: X3 (E83) Forum 10-31-2011, 10:48 PM
Replies: 13
Views: 3,004
Posted By 04X3
Headlight Washer

About a month after getting my car back from home up to its new home, the headlight washers seem to have stopped working. All four of them. I can hear the pump go when I activate the headlight washer...
Showing results 1 to 4 of 4

 
Forum Jump



All times are GMT -4. The time now is 12:31 AM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.