Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Search Forums
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Showing results 1 to 6 of 6
Search took 0.01 seconds.
Search: Posts Made By: BlkE53FRMCALI
Forum: X5 (E53) Forum 07-11-2019, 08:29 PM
Replies: 7
Views: 278
Posted By BlkE53FRMCALI
My bad. 03 4.4i sport Sent from my iPhone...

My bad. 03 4.4i sport


Sent from my iPhone using Xoutpost.com (http://r.tapatalk.com/byo?rid=95438)
Forum: X5 (E53) Forum 07-11-2019, 08:25 PM
Replies: 7
Views: 278
Posted By BlkE53FRMCALI
Forgot to mention itís an 03 X5 4.4i ...

Forgot to mention itís an 03 X5 4.4i


Sent from my iPhone using Xoutpost.com (http://r.tapatalk.com/byo?rid=95438)
Forum: X5 (E53) Forum 07-11-2019, 08:13 PM
Replies: 7
Views: 278
Posted By BlkE53FRMCALI
Transmission issues HELP!

Iím having transmission issues and itís starting to get frustrating.

When I drive the car on a cold start everything is fine. Shifts smoothly and no issues. When it warms up is when I start...
Forum: X5 (E53) Forum 06-24-2019, 09:24 PM
Replies: 5
Views: 404
Posted By BlkE53FRMCALI
Thatís what Iím thinking as it all acquired after...

Thatís what Iím thinking as it all acquired after Messing with the harness. Itís all electrical with these cars, just gotta be smarter. Iíll look into getting that spray.


Sent from my iPhone...
Forum: X5 (E53) Forum 06-24-2019, 06:03 PM
Replies: 5
Views: 404
Posted By BlkE53FRMCALI
Where would I be able to find the connector...

Where would I be able to find the connector below? Also, all of this didnít start happening till the abs was swapped.


Sent from my iPhone using Xoutpost.com (http://r.tapatalk.com/byo?rid=95438)
Forum: X5 (E53) Forum 06-24-2019, 04:21 PM
Replies: 5
Views: 404
Posted By BlkE53FRMCALI
Desperately NEED HELP! E53 trouble

Hey guys,

I'm new to the beamer world and at a loss with my 03 E53. I had to replace my ABS module as it got fried and also had to replace the harness. When I did that I did not realize that it...
Showing results 1 to 6 of 6

 
Forum Jump



All times are GMT -4. The time now is 12:40 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.