Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Search Forums
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Showing results 1 to 25 of 344
Search took 0.04 seconds.
Search: Posts Made By: turquise1
Forum: X5 (E53) Forum 02-17-2021, 03:18 PM
Replies: 15
Views: 1,216
Posted By turquise1
I think a tool like that is a good investment for...

I think a tool like that is a good investment for BMW DIY work..

Launch has a 'pros mini' option that is relatively cheap ($800) compared to Autel with same functionality. When I contacted Autel,...
Forum: X5 (E53) Forum 02-17-2021, 12:28 PM
Replies: 15
Views: 1,216
Posted By turquise1
So after returning both scanners, I have decided...

So after returning both scanners, I have decided to invest in something more expensive and got the Launch X431. I also cleaned the connections to DME and tested the system using the Launch and I can...
Forum: X5 (E53) Forum 02-13-2021, 01:43 PM
Replies: 15
Views: 1,216
Posted By turquise1
Here are the photos of the connectors. I even...

Here are the photos of the connectors. I even thought they were missing pins or something but the photos did not look like it.

For the wiring process, I did the 20 pin connection of 20 and 17 and...
Forum: X5 (E53) Forum 02-13-2021, 12:18 PM
Replies: 15
Views: 1,216
Posted By turquise1
I have tried every possible wiring including your...

I have tried every possible wiring including your setup without success unfortunately. Only INPA works from under the hood. 530 is already gone and I am about to return icarsoft 3.0 too.


Thanks,...
Forum: X5 (E53) Forum 02-12-2021, 04:16 PM
Replies: 15
Views: 1,216
Posted By turquise1
A good BMW scanner for the picky E53 4.4?

Hey ppl,

You guys recommend a decent scanner / tester for a BMW?

I have been using a basic one for a while and the more complicated things I started to work on, the more I needed to test...
Forum: X5 (E53) Forum 12-28-2020, 03:29 PM
Replies: 52
Views: 2,580
Posted By turquise1
Update : Replaced the exhaust manifold...

Update :

Replaced the exhaust manifold gaskets (bank 2) and the ticking is still there. Not sure how to proceed from here. I may do another leak test to see if the manifold itself actually has a...
Forum: X5 (E53) Forum 12-11-2020, 02:26 PM
Replies: 52
Views: 2,580
Posted By turquise1
You should have taken photos of your work. I am...

You should have taken photos of your work. I am still not sure how you managed it. I can only reach half of the bolts from the top and I could not see the back ones from the bottom (yet) :)
...
Forum: X5 (E53) Forum 12-11-2020, 01:18 PM
Replies: 52
Views: 2,580
Posted By turquise1
Update : From what I can hear, the ticking...

Update :

From what I can hear, the ticking (at least most of it) comes from the driver's side exhaust manifold. I looked in there with a borescope and there is definitely some carbonized areas...
Forum: X5 (E53) Forum 11-29-2020, 12:24 PM
Replies: 52
Views: 2,580
Posted By turquise1
Would this be more accurate than using a...

Would this be more accurate than using a mechanic's stethoscope? Using the stethoscope I hear the ticking everywhere although I thought it was the strongest when I touched the bottom of the manifold....
Forum: X5 (E53) Forum 11-28-2020, 01:42 PM
Replies: 52
Views: 2,580
Posted By turquise1
Update : After all the repairs (replacement...

Update :

After all the repairs (replacement of valve seals, cleanup of oil passages inside cylinder head, cleaning inside the combustion chamber) and putting the new lifters in, there is still the...
Forum: X5 (E53) Forum 10-18-2020, 11:09 AM
Replies: 52
Views: 2,580
Posted By turquise1
I have been looking at other threads as well....

I have been looking at other threads as well. This one mentions the check valve between block and cylinder head clogging causing the issue..
...
Forum: X5 (E53) Forum 10-17-2020, 08:29 AM
Replies: 52
Views: 2,580
Posted By turquise1
Yep, no rockers on M62. I think they have them on...

Yep, no rockers on M62. I think they have them on the next version N62. I think I am just going to replace the lifters at this point and see what happens. It's very tempting right now to replace the...
Forum: X5 (E53) Forum 10-16-2020, 09:07 PM
Replies: 52
Views: 2,580
Posted By turquise1
My guess at this point is the old lifters (one or...

My guess at this point is the old lifters (one or many) are not fully expanding (or not recovering) after compression. There is no new lifter in there yet. Some are the originals and some are picked...
Forum: X5 (E53) Forum 10-16-2020, 02:46 PM
Replies: 52
Views: 2,580
Posted By turquise1
So, I did some quick comparison of old vs. new...

So, I did some quick comparison of old vs. new lifters. I emptied the oil out of them first and the new one has .5 - .6 mm more piston extension compared to old one. That number seems to get worse...
Forum: X5 (E53) Forum 10-16-2020, 12:48 PM
Replies: 52
Views: 2,580
Posted By turquise1
Isn't the tick caused by the space between the...

Isn't the tick caused by the space between the cam lobe - lifter or lifter - valve tip (some valve tips are hammered and flattened which is a sign of a bad lifter?)? So wouldn't that number have to...
Forum: X5 (E53) Forum 10-16-2020, 11:31 AM
Replies: 52
Views: 2,580
Posted By turquise1
I tried to squeeze each and did not feel or see...

I tried to squeeze each and did not feel or see any movement. I thought there would be big movement to make such a loud tick. :)
I did not measure with a caliper. I guess I can try that as well..
...
Forum: X5 (E53) Forum 10-16-2020, 11:20 AM
Replies: 52
Views: 2,580
Posted By turquise1
You are right on that as well. So it would have...

You are right on that as well. So it would have to have the timing chains back on and correctly timed for that to avoid harming the valves. Thanks for the warning..


Ozzie
Forum: X5 (E53) Forum 10-16-2020, 11:17 AM
Replies: 52
Views: 2,580
Posted By turquise1
Hey Andrew, The lifters all came out full...

Hey Andrew,


The lifters all came out full of oil and none of them was collapsed but I see your point. They may certainly act differently under heavy pressure from the cam lobes. They may briefly...
Forum: X5 (E53) Forum 10-16-2020, 11:06 AM
Replies: 52
Views: 2,580
Posted By turquise1
Hey Purplefade, So you think I should put...

Hey Purplefade,


So you think I should put the cams on and rotate them by hand to see if there is any ticking? I thought about that but I wasn't sure if I would have enough power to rotate them....
Forum: X5 (E53) Forum 10-16-2020, 10:57 AM
Replies: 52
Views: 2,580
Posted By turquise1
Hey Andrew, I have already mentioned that...

Hey Andrew,


I have already mentioned that I think. It's 300 ticks a min at 600 rpm so it's half..


Thanks,
Forum: X5 (E53) Forum 10-15-2020, 07:58 PM
Replies: 52
Views: 2,580
Posted By turquise1
So, after replacing the valve stem seals (most of...

So, after replacing the valve stem seals (most of them badly worn out) and not seeing any damage on the springs to cause ticking, I decided to look at the cams one more time. They are definitely worn...
Forum: X5 (E53) Forum 10-13-2020, 11:19 AM
Replies: 52
Views: 2,580
Posted By turquise1
I have looked at the bores but did not see much...

I have looked at the bores but did not see much damage. Some of them are slightly worn causing some lifters to very minimally move side to side but not sure that would cause the issue. I also did not...
Forum: X5 (E53) Forum 10-03-2020, 11:10 PM
Replies: 52
Views: 2,580
Posted By turquise1
What would you mean by that? Some sort of...

What would you mean by that? Some sort of blockage pressuring oil more towards some lifters and less towards others?

The ticking seems to come from bank 2. There is also spark plug oil fouling on...
Forum: X5 (E53) Forum 10-03-2020, 07:36 PM
Replies: 52
Views: 2,580
Posted By turquise1
Injectors were what I thought was the problem...

Injectors were what I thought was the problem first when I used a stethoscope to pinpoint the problem. I replaced / cleaned out all of them and did not make any difference.

A mechanic friend told...
Forum: X5 (E53) Forum 10-03-2020, 05:06 PM
Replies: 52
Views: 2,580
Posted By turquise1
One thing I am noticing is a lot of thick dirt...

One thing I am noticing is a lot of thick dirt particles (like small pieces of mud) in the oil in there which makes me think those thin oil lines maybe partially or fully clogged. Would it be...
Showing results 1 to 25 of 344

 
Forum Jump



All times are GMT -4. The time now is 03:55 AM.
vBulletin, Copyright 2021, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.