Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Search Forums
Bimmer Tool Rental
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Showing results 1 to 25 of 85
Search took 0.05 seconds.
Search: Posts Made By: CLS70
Forum: X5 (E70) Forum 09-27-2019, 10:13 PM
Replies: 39
Views: 1,434
Posted By CLS70
My "must-have" options (BMW in general, not X5...

My "must-have" options (BMW in general, not X5 specific):

1. Cold weather Package (I'm in Canada = Heated Seat (F+R) + Heated Steering Wheel) - this is a complete deal breaker
2. Comfort Seats ...
Forum: X5 (E70) Forum 06-22-2019, 12:04 PM
Replies: 2
Views: 312
Posted By CLS70
Transfer Case Issue (?)

Hi -

Seems I have a Transfer Case issue - was checking the front suspension and found that, with both front wheels in the air, if I move the wheels rapidly back and forth (e.g. 20 degrees back &...
Forum: X5 (E70) Forum 06-22-2019, 11:59 AM
Replies: 4
Views: 229
Posted By CLS70
Thanks - I checked these (at least what can be...

Thanks - I checked these (at least what can be seen) and there is no pieces falling or visible signs of damage

So far I believe the lower control arms have quite a bit of play and seem to be a...
Forum: X5 (E70) Forum 06-18-2019, 07:09 PM
Replies: 4
Views: 229
Posted By CLS70
Radiator Loose

Hi

I'm chasing a clunk noise in the front. When looking for "stuff" that could be the culprit, noticed that the radiator/electric fan assembly is loose, or at least I can easily move it front/back...
Forum: X5 (E70) Forum 06-18-2019, 06:58 PM
Replies: 12
Views: 546
Posted By CLS70
Can't comment about your specific technical issue...

Can't comment about your specific technical issue / situation

What I can tell you is that I have taken my running (=NO CEL lights, NO Issues) car(s) to the dealer for recall work in two occasions...
Forum: X5 (E70) Forum 06-03-2019, 01:57 PM
Replies: 9
Views: 345
Posted By CLS70
Thanks all Just to provide an update - ...

Thanks all

Just to provide an update -

- Installed the new Hose (that comes without a hole for the sensor) - fits perfectly

- Bought the required "Resistance" part (at the Dealer) that...
Forum: X5 (E70) Forum 05-23-2019, 12:07 AM
Replies: 5
Views: 333
Posted By CLS70
There are TWO versions of the Roof Bars, they...

There are TWO versions of the Roof Bars, they look almost identical but they are not. I had the same issue as you and bought the wrong ones.

There is a version for X5s with 'Regular' roof rails,...
Forum: X5 (E70) Forum 05-22-2019, 11:55 PM
Replies: 9
Views: 345
Posted By CLS70
Yes, that is exactly how the current hose looks...

Yes, that is exactly how the current hose looks like !!
Forum: X5 (E70) Forum 05-22-2019, 11:54 PM
Replies: 9
Views: 345
Posted By CLS70
So it seems the Hose was revised. Same part...

So it seems the Hose was revised. Same part number though.

The new version does not have a slot for the Sensor (?) and when buying, you are supposed to buy a resistor that plugs into the Sensor...
Forum: X5 (E70) Forum 05-17-2019, 06:03 PM
Replies: 9
Views: 345
Posted By CLS70
2007 x5 Radiator Hose Question

Hi
I'm replacing one of the coolant hoses (part 17-127-537-108); checked in RealOEM and bought the part.
When replacing, the hose that is currently in the car is different (WTH?), as it has an...
Forum: X5 (E70) Forum 01-07-2019, 06:34 PM
Replies: 8
Views: 406
Posted By CLS70
Thanks - Will keep an eye the next few days and...

Thanks - Will keep an eye the next few days and will try different settings to see what could be the root cause; the sensor seems odd and could have been just a conincidence. I found a detailed...
Forum: X5 (E70) Forum 01-06-2019, 11:48 AM
Replies: 8
Views: 406
Posted By CLS70
Thx - I went to check the filters for obstruction...

Thx - I went to check the filters for obstruction and noticed the box air quality sensor was not fully connected; plugged in tight and then all went back to normal.....
Forum: X5 (E70) Forum 12-19-2018, 06:40 PM
Replies: 8
Views: 406
Posted By CLS70
Unhappy Vents not working - any setting

Hi
In the last week or so, the Vents settings (X5 e70 3.0 si) are not working at all. It does not matter which setting I select in iDrive or how I set the distribution of air (Cold/Hot,...
Forum: X5 (E70) Forum 10-02-2018, 10:20 PM
Replies: 21
Views: 4,350
Posted By CLS70
New = <<Left Old = Right>> The Old one was...

New = <<Left
Old = Right>>

The Old one was hardened and less flexible
Forum: X5 (E70) Forum 10-02-2018, 09:09 PM
Replies: 21
Views: 4,350
Posted By CLS70
Yes, I picked the old O-ring out and put the new...

Yes, I picked the old O-ring out and put the new one back into the inside of the hose end / plastic connector.
Forum: X5 (E70) Forum 10-01-2018, 03:39 PM
Replies: 21
Views: 4,350
Posted By CLS70
@e70Jane: At the end I think my leak was in...

@e70Jane:

At the end I think my leak was in the Hose connection; I replaced the Tank and replaced the O-ring inside the connection (inside the plastic end of the hose), will post pictures of the...
Forum: X5 (E70) Forum 09-30-2018, 05:56 PM
Replies: 3
Views: 369
Posted By CLS70
Thanks - need to figure out how to unplug it...

Thanks - need to figure out how to unplug it (checked RealOEM but no idea how to reach there). I have been checking it more and I will be more inclined to believe it is some sort of engine issue.
...
Forum: X5 (E70) Forum 09-26-2018, 10:32 AM
Replies: 3
Views: 369
Posted By CLS70
Hesitation - Slow Turn

Hi

I have an X5 3.0 si with 180K KM. Lately I have been noticing a hesitation when accelerating after a slow turn. I can replicate the behaviour roughly 50% of the time.

It happens when I'm...
Forum: X5 (E70) Forum 09-13-2018, 07:50 PM
Replies: 21
Views: 4,350
Posted By CLS70
After further testing, the connection leaks....so...

After further testing, the connection leaks....so with no available parts, decided to check if there was an O-Ring in the connection; there was one, fairly worn and flat so took it out and managed to...
Forum: X5 (E70) Forum 09-13-2018, 01:47 PM
Replies: 21
Views: 4,350
Posted By CLS70
Got the new tank and replaced it; took out ~ 3...

Got the new tank and replaced it; took out ~ 3 litres of coolant before but still a bit of spill from the hose that connects to the bottom.

I could not find a leak or crack on the old tank but it...
Forum: X5 (E70) Forum 09-11-2018, 05:45 PM
Replies: 21
Views: 4,350
Posted By CLS70
Hi there - having EXACTLY the same issue - took...

Hi there - having EXACTLY the same issue - took me a bit to get the source of the coolant leak but this post helped me a lot - I cleaned up the area and then proceeded to wiggle the hose / connection...
Forum: X5 (E70) Forum 09-06-2018, 04:09 PM
Replies: 39
Views: 2,659
Posted By CLS70
Thx. Interesting....not sure what else could be...

Thx. Interesting....not sure what else could be around there... the Realoem diagrams maybe useful but they do not show the whole picture......
Forum: X5 (E70) Forum 09-06-2018, 03:34 PM
Replies: 13
Views: 968
Posted By CLS70
Re. 2 Ton I think it may be too small - I used...

Re. 2 Ton
I think it may be too small - I used to have a 2.5 Ton jack for changing Winter Tires (one corner at a time) and it was seriously at its limit....I bought a 5 Ton and made a lot of...
Forum: X5 (E70) Forum 09-06-2018, 03:24 PM
Replies: 39
Views: 2,659
Posted By CLS70
Just another angle; what if the clunk/noise is...

Just another angle; what if the clunk/noise is not coming from the suspension? what about inside? could be the battery being loose or somewhere around there that got dislodged by the bump?
Forum: X5 (E70) Forum 06-29-2018, 09:57 AM
Replies: 47
Views: 3,666
Posted By CLS70
+ 1 @mkelly21 - over time, repairs start...

+ 1

@mkelly21 - over time, repairs start adding up (and will continue to do so), my experience is that doing anything* at the dealer is $$$$, on a good shop** a bit cheaper and DIY*** saves you...
Showing results 1 to 25 of 85

 
Forum Jump



All times are GMT -4. The time now is 09:23 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.