Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Search Forums
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Showing results 1 to 7 of 7
Search took 0.01 seconds.
Search: Posts Made By: Maxi840ci
Forum: X5 (E53) Forum 05-20-2020, 12:35 PM
Replies: 31
Views: 6,876
Posted By Maxi840ci
pretty sure all the air in the ABS came out on...

pretty sure all the air in the ABS came out on the first line once I was doing the proper bleed routine
Forum: X5 (E53) Forum 05-20-2020, 12:32 PM
Replies: 31
Views: 6,876
Posted By Maxi840ci
If you have a pressure bleeder and you have a...

If you have a pressure bleeder and you have a safe way to catch the fluid, then you can do by yourself. If you run the service function and hear the abs pumping you can get quickly back to the...
Forum: X5 (E53) Forum 05-20-2020, 11:53 AM
Replies: 31
Views: 6,876
Posted By Maxi840ci
Brake bleeding solved with Ista-D

2006 E53 4.4
If you ever get air in the ABS, seems impossible to remove without bmw software. I managed to get ista-D installed. Once connected, the correct function is under "vehicle...
Forum: X5 (E53) Forum 07-19-2017, 01:34 PM
Replies: 14,649
Views: 2,140,604
Posted By Maxi840ci
Custom made copy of the fluid motor union x5...

Custom made copy of the fluid motor union x5 bumper.
Forum: X5 (E53) Forum 07-19-2017, 12:16 PM
Replies: 14,649
Views: 2,140,604
Posted By Maxi840ci
Took the X5 offroad

$1200 Craigslist find with smashed radiator. It actually does well on class II trails. 2" lift 32" mud tires.
Forum: X5 (E53) Forum 07-18-2017, 08:29 AM
Replies: 2
Views: 701
Posted By Maxi840ci
One bulb

One bulb
Forum: X5 (E53) Forum 07-18-2017, 12:11 AM
Replies: 2
Views: 701
Posted By Maxi840ci
Xenon issue

Hello, I have an issue with low beam xenon. I have replaced everything and still won't turn on. I've swapped headlights left to right and confirmed there's no issue with my bulbs/ballast/alc module....
Showing results 1 to 7 of 7

 
Forum Jump



All times are GMT -4. The time now is 10:13 AM.
vBulletin, Copyright 2022, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.