Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E53) Forum (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/)
-   -   Bad alternator or battery??? (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/110501-bad-alternator-battery.html)

E53blue4.8is 07-04-2019 08:33 AM

Bad alternator or battery???
 
Hey guys, I have a 2006 4.8is that I've had for a couple of months. Its had an intermittent issue that when driving all of a sudden, the dsc off, 4x4, and brake lights come on all at once. The radio screen would also go blank and I'd lose radio sound too. After all that, it would kick into trans failsafe mode. It's been starting to do it pretty every time I drive now. And if I shut it off while the lights are on, the battery is dead and I'll have to jump it. I'm not sure if it's the alternator that isn't charging, or there's a bad cell in the battery or something. Both were new in November and only have about 5000 miles on them. The previous owner had them installed at a midas location. Thoughts??

EODguy 07-04-2019 08:39 AM

What does your hidden menu say that voltage is while running?

Sent from my SM-A730F using Tapatalk

E53blue4.8is 07-04-2019 08:55 AM

It doesn't stay on long enough to tell. It always kicks off to tell me myself leveling air suspension is inactive.

crystalworks 07-04-2019 10:45 AM

Alternator. And if the battery has been flat multiple times without being trickle charged back up... it might be dead again too. Midas probably used a rebuilt or aftermarket alternator that isn't performing.

E53blue4.8is 07-04-2019 10:56 AM

That's what I was figuring too. Just wanted other people's input before i dropped the money on it since they aren't cheap.

crystalworks 07-04-2019 11:30 AM

Quote:

Originally Posted by E53blue4.8is (Post 1165306)
That's what I was figuring too. Just wanted other people's input before i dropped the money on it since they aren't cheap.

Monitoring your voltage is the best way to definitively diagnose it. But that's my guess and where I'd put my money.

SlickGT1 07-05-2019 12:00 AM

I don’t know. Mine was voltage regulator. Like $40 from bmw. Car was doing some
Stupid shit too. Trans failsafe, susp inactive, brakes light would turn on. Navi reboot. Guess what. Overvoltage. Not Under voltage.

I would scan it. Inpa will pick up a code if it’s low bat or over voltage.

E53blue4.8is 07-05-2019 08:40 AM

Quote:

Originally Posted by SlickGT1 (Post 1165328)
I donít know. Mine was voltage regulator. Like $40 from bmw. Car was doing some
Stupid shit too. Trans failsafe, susp inactive, brakes light would turn on. Navi reboot. Guess what. Overvoltage. Not Under voltage.

I would scan it. Inpa will pick up a code if itís low bat or over voltage.

You don't happen to have a part number, do you?

crystalworks 07-05-2019 10:31 AM

Quote:

Originally Posted by SlickGT1 (Post 1165328)
I donít know. Mine was voltage regulator. Like $40 from bmw. Car was doing some
Stupid shit too. Trans failsafe, susp inactive, brakes light would turn on. Navi reboot. Guess what. Overvoltage. Not Under voltage.

I would scan it. Inpa will pick up a code if itís low bat or over voltage.

It probably is the VR. When mine failed it would have both under and over voltage issues. I consider a VR failure an alternator failure and just replace the whole thing but, like yourself, many here have just replaced the VR and been back in business.

andrewwynn 07-05-2019 10:55 AM

i rebuilt my alternator with a $20 kit (for Valeyo). vs $325 for whole alternator.


All times are GMT -4. The time now is 04:47 PM.

vBulletin, Copyright 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved.