View Single Post
  #7  
Old 12-17-2016, 01:24 AM
oldskewel oldskewel is offline
Member
 
Join Date: Nov 2014
Location: SF Bay Area
Posts: 724
oldskewel is on a distinguished road
Quote:
Originally Posted by Webprogramma View Post
2005 X5 4.4i V8

So, I took the plate off to get to the starter since the battery was dead and I couldn't get into the car. I got into the car and have a new battery and need to put the plate back on.

I have read many posts about these bolts/fasteners being 1 time use. I have seen old posts where these bolts used to be $3 each. Are they really $16 each now?

This X5 was not driven hard and the bolts have no real wear at all. Please take a look and let me know if you think that I'm safe to use these bolts again.

I just bought the vehicle and the radio doesn't work. I was told that the amp needed to be replaced. I believe it got wet. The car has an extended warranty and I just need to get it to a shop so that they can check out the amplifier and maybe order a new one.

Anyone know where I can get some cheaper screws? Would still like to use what I have if I can.

Thank you in advance.
I've re-used mine. Just be aware that you can't use the same torque procedure (initial torque + angle after that) when you re-use them. You want to get back to the same amount of tightness without causing any more plastic deformation. If you were to use the same procedure multiple times you would certainly push it further into the deformation zone until it breaks.

On the radio, if it is still getting wet there, it is likely to be a problem with the hose leading from the left rear corner of the sunroof. Common problem on these cars, easy to test, easy to fix. Whatever it is, of course you should make sure the leak is fixed before replacing the stereo.
__________________
2001 X5 3.0i, 180k miles, AT, owned since 11/2014
Reply With Quote

Sponsored Links