View Single Post
  #2  
Old 03-25-2019, 08:44 AM
upallnight's Avatar
upallnight upallnight is offline
Member
 
Join Date: Aug 2012
Location: Cook County
Posts: 7,280
upallnight is on a distinguished road
Quote:
Originally Posted by oldblue1993 View Post
So hopefully someone can point me in a direction of something that I have not tried yet. My x5 runs great idle is as smooth as a brand new car, but when going down the road with a light foot on the gas it stutters and the dreaded check engine light comes on but goes back to running fine.
The codes I am getting are secondary-air hot-film air mass sensor, trimming 02 before cat bank 1 and trimming before cat bank 2.

I have replaced disa valve, replaced CCV, cleaned Iac "all new gaskets well I was there, new plugs, new mass air flow sensor and had it smoke tested to be sure of no leaks.I also changed fuel filter and verified pressure.

I have read numerous thing on this and have tried almost everything, could the secondary mass be part of the trouble?

If anyone has a thought please share as I am ready to give up, but am in to deep to stop.
What type of Mass Air Flow sensor did you replace the original with? Was it a genuine Siemens MAF or so cheap MAF that you bought on eBay or Amazon. If you didn't buy a genuine Siemens MAF that is your problem.
__________________
2006 Infiniti G35
2001 BMW 3.0I E53 X5 Build date 08/2000 SOLD
Lotus Europa 1970 Destroyed by fire
Lotus Europa 1970 S2 Renault Powered
Lotus Type 52 1970 Twincam Webers Powered
PORSCHE 911 Targa 1982 The Garage Queen
Audi Avant donated to Kars for Kids
BMW 525IT Sold
Audi 4000CS Quattro Sold
Jensen Healey Lotus Powered Sold
Opel 1900 Sold
Triumph Spitfire 1971 Sold
Triumph Spitfire 1968 Sold
Plymouth "Cuda" 340 Six pack SOLD
Reply With Quote

Sponsored Links