View Single Post
  #2  
Old 01-01-2012, 11:16 PM
nachilus nachilus is offline
Member
 
Join Date: Aug 2011
Location: MD
Posts: 74
nachilus is on a distinguished road
Quote:
Originally Posted by FTW Gaj View Post
First off I've just signed up so hello all!!

I'm hoping someone might be able to help me understand a few issues I'm having with my 2007 E70 3.0d. I keep getting a warning message saying "transmission faulty - position P may not be available". It's an intermittent problem, but there's a stack of other little issues too. My PDC nearly always shows red on the two front right sectors, I sometimes get the BMW home screen on the idrive on start up and the idrive screen sometimes stays black for up to 30s on start up, and has completely frozen on occaision.

It's been into the dealer 4 times, and now booked in for a week for further diagnostics, but only once have they found a fault code needing the car to be completely reprogrammed, but didn't solve the problem.

I can't fault the dealer, as they've been top notch in making sure I'm not inconvenienced but I want a car that works properly.

Anyone had any similar issues, and how were they resolved?

Thanks for reading, and for any advice:-)

Andy

My 07 4.8 X went in for a check engine light and a faulty nav, its been there for 53 days now. Once they replaced the gateway, all sorts of electrical issues popped up. BMW sent specialists out to resolve the issue the another popped up. They assured me the issue is resolved and I will be picking the car up this week. I am keeping my fingers crossed.
__________________
2007 X5 4.8 |Space Grey | Sport Package | Cold Weather Package | Premium Sound Package | Active Steering | Rear seat entertainment | Premium Package | Rear Climate Package | Technology Package | Comfort Access | Multi-contour seats w/lumbar | 3rd row seat | iPod and USB adapter | Running boards | Wheels Arches | 214, 20" Wheels |

05' Mercedes S55 ///AMG
05' 745 IL (Sold)
01' 740 IL (Sold)
04' Yukon Denali
Reply With Quote

Sponsored Links