Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X ///M Forum (https://xoutpost.com/bmw-sav-forums/x-m-forum/)
-   -   X5 M Turbo broken? (https://xoutpost.com/bmw-sav-forums/x-m-forum/103544-x5-m-turbo-broken.html)

mirob 04-11-2016 07:25 AM

X5 M Turbo broken?
 
Here is a video I took earlier today. It's on a 2011 X5 M with 57K miles.

It's me moving the camera/phone from one intake bank to the other, with the housing removed. The left/passenger bank is making the sound, which I can only describe as a wobble. There is no sound coming from the other intake bank, besides the background noise.

Not sure if it's the turbo going out or maybe some sort of exhaust leak making the sound but I'm preparing for the worst.

If it's the turbo, may replace both with Pure Turbos.

Anyone hear anything like this before? Deal with this issue? Any help or suggestions would be appreciated.

Thanks.

https://youtu.be/s3N1jkQP6ZU

electricalserv x5 04-17-2016 07:34 PM

that's I stick with the e53

mirob 04-18-2016 03:14 PM

Quote:

Originally Posted by electricalserv x5 (Post 1075776)
that's I stick with the e53

Yeah, had that 4.8iS too...the headache with the Self Leveling Suspension (amongst other things) was bigger than anything I've experienced so far in the E70 (including injectors).

Joshdub 04-22-2016 07:30 PM

how does the turbo sound under load? I haven't heard that noise coming from a turbo before.

mirob 04-22-2016 07:56 PM

Quote:

Originally Posted by Joshdub (Post 1076184)
how does the turbo sound under load? I haven't heard that noise coming from a turbo before.

Good question. I'm not sure, I haven't tried to put it under load to see if anything changes. I'll try to record and post it.

mirob 04-23-2016 02:59 PM

The frequency of the sound increases with throttle imput.

https://youtu.be/JzxWSm3HVTA

m5james 05-20-2016 09:13 PM

What ever came of this?

mirob 05-20-2016 09:49 PM

Quote:

Originally Posted by m5james (Post 1078504)
What ever came of this?

No updates as of yet. I was following up a lead that my vacuum pump may be loose and making the sound but that injector deal derailed me.

m5james 05-20-2016 10:07 PM

1 Attachment(s)
Just like everything what N63 related, my vacuum pump had issues as well...apparently it was only leaking though.

mirob 05-20-2016 10:12 PM

Quote:

Originally Posted by m5james (Post 1078511)
Just like everything what N63 related, my vacuum pump had issues as well...apparently it was only leaking though.

Yeah, it's been hell of a ride (pun intended). Having some buyers remorse. Should have grabbed an E92 M3 instead.


All times are GMT -4. The time now is 01:26 AM.

vBulletin, Copyright 2021, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.