Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X3 (E83) Forum (https://xoutpost.com/bmw-sav-forums/x3-e83-forum/)
-   -   E83 X3 with 2A80 VANOS activation (https://xoutpost.com/bmw-sav-forums/x3-e83-forum/108570-e83-x3-2a80-vanos-activation.html)

Latterlon 08-01-2018 03:44 PM

E83 X3 with 2A80 VANOS activation
 
I own a 2008 X3 with 126,000 miles. Recently it gave the 2A82 and 2A87 codes which were cleared and returned. I purchased two new VANOS solenoids on Amazon and had my mechanic replace those. He did try and relearn the system, which I didn't believe was necessary for this repair, but I now have a "2A80 Intake VANOS activation" code which cannot be erased with my C110 scanner. The car idles rough on startup then drives but with reduced power.

I cannot really pinpoint the 2A80 fault as it is not prevalent on the forums.

I also have the triad and had him replace the actuator gear, but the fluid wear code is on and the lights won't go off. I know I need to replace the fluid and maybe clear that with some of the software available...?

Any help is appreciated.

shark88 12-02-2018 08:52 PM

Not sure where your Amazon solenoids were manufactured. I recently replaced the ones on my daughters 2006 E90 with a name brand but made in China from RockAuto. One failed within a week so I bit the bullet and bought 2 OEM's from FCP Euro. These cleared the codes and have been working fine since. RockAuto did give me a full refund for both and FCP give you a lifetime warranty on their parts.


All times are GMT -4. The time now is 10:34 PM.

vBulletin, Copyright 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.