Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E53) Forum (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/)
-   -   Airbag Connection Fix (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/113172-airbag-connection-fix.html)

Red911t 04-18-2021 04:01 PM

Airbag Connection Fix
 
Hello all, I replaced my front driver door carrier, and like a moron, disconnected the airbag....now I have a fault code. I have plugged the airbag back in, turned on the car, and gone through my Foxwell 510 to reset the light - when I hit erase code, the light turns off, blinks on and off, then comes back on to stay.

Any idea why it is not turning off through the system here? I've been following what various YouTube videos say to do when going through, but my blinks off and then back on again. Any help is appreciated!

Tim

upallnight 04-18-2021 04:56 PM

Erase the code, disconnect the battery for about 30 minutes and reconnect the battery.

Red911t 04-18-2021 05:06 PM

Dumb question but when I erase the code the light comes on 20 seconds later. Do I have to sprint to unhook the battery or does that not matter in terms of timing

Clavurion 04-18-2021 05:21 PM

Does it tell on the code if it's for too high or too low resistance? Did you possibly break the plastic splices on the locking part of the airbag connector?

Red911t 04-18-2021 05:26 PM

Yes I do think I broke the splices. Itís odd because the connection isnít loose, it takes a good tug to remove, but maybe itís because the clip is not forcing the connection tighter?

oldskewel 04-18-2021 06:41 PM

Quote:

Originally Posted by Red911t (Post 1202732)
Hello all, I replaced my front driver door carrier, and like a moron, disconnected the airbag....now I have a fault code. I have plugged the airbag back in, turned on the car, and gone through my Foxwell 510 to reset the light - when I hit erase code, the light turns off, blinks on and off, then comes back on to stay.

Any idea why it is not turning off through the system here? I've been following what various YouTube videos say to do when going through, but my blinks off and then back on again. Any help is appreciated!

Tim

Just to try to help by confirming what should have happened:

disconnecting the airbag while the car battery is still connected ==> yes, that properly sets the airbag light which then remains until it gets reset with a special tool such as the Foxwell. BTW I do this just about every time I open up a door on my 2001 3.0i. I know the light will be set, and successfully rely on the Foxwell (and previously a different, airbag-reset-only tool)

Using the Foxwell to reset the airbag light ==> yes, that should clear it, not requiring any other steps such as battery disconnection.

So my thinking is that since the Foxwell reset is not holding, you must have something broken there. So reading the actual code might help confirm, figuring out what you may have snapped, etc.

One additional random fact that may or may not be useful ... That special-purpose airbag tool (eBay, $20, Chinese, called something like 8800) I had before I got the Foxwell worked very reliably, but every single time, it took two reset cycles for the reset to work. I never figured out why, and did not worry since it always worked on the second try. I don't think my Foxwell NT520 Pro has this issue. But you might try doing the reset twice in a row to see if anything changes (if you have not already done so). Just a guess. Good luck.

Clavurion 04-18-2021 07:22 PM

The purpose of those thin plastic tabs on the locking part is to separate shorting splines from pins on the airbag side connector.

https://www.e46fanatics.com/attachme..._b-jpg.318332/

https://www.e46fanatics.com/attachme..._1-jpg.318311/

https://www.e46fanatics.com/attachme..._2-jpg.318312/

Red911t 04-19-2021 09:43 AM

Ok, just ordered a new door harness off ebay so I can pull the spline/clip thing for the airbag connector. Hopefully that secures the connection properly and i can reset without issue.

Red911t 04-23-2021 03:15 PM

Help, I am still in airbag hell. The door harness came, I swapped the airbag connection clip, started the car up.....and the light is still on. Go to reset via the Foxwell, it goes off, blinks on, then off, then comes back on permanently.

I also disconnected the battery for awhile, hooked it back up, airbag light is still on. Any other ideas?

Tim

crystalworks 04-23-2021 03:38 PM

What SRS code is your foxwell reporting when you scan it?


All times are GMT -4. The time now is 06:00 AM.

vBulletin, Copyright 2021, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved.