Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E53) Forum (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/)
-   -   Some Electrical quirks (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/91199-some-electrical-quirks.html)

mrothwell 02-01-2013 01:00 PM

Some Electrical quirks
 
I have a 2001 X5 4.4 sport with NAV.

Lately, I have been having a few little electrical quirks pop up. I dont know if they are related or not:

1. Occasionally the rear hatch gets opened without any buttons being pushed. I hear the latch release, altho it only does a half release. I go and open the hatch and close it again and it is fine. Usually, this seems to happen at a stop light or parking lot.

2. On the NAV/radio, it used to always come on with the radio display at the top, and the trip/computer info on the bottom. Lately it takes a few seconds before turning on when I start the vehicle then usually comes on asking which function I want to go to. If I power the radio off/on then it comes back on with the radio display at the top again.

3. At startup, I sometimes get a message to check brake lights and/or tail lights. Sometimes it's only one of the 2, sometimes both. I have checked and the tail lights and brake lights appear to be working as expected.

Any ideas on what I need to be looking for?

epdarks 02-01-2013 01:17 PM

First and easiest check is going to be your battery. Any idea if it could use replacement?

TerminatorX5 02-01-2013 01:27 PM

battery...

mrothwell 02-01-2013 01:31 PM

Battery appears strong. I've never had an issue with it struggling to start the car, even in -20 degree temperature after sitting for a couple days.

TerminatorX5 02-01-2013 03:33 PM

test the battery by the numbers - there are multiple recent threads about it... the X is super sensitive to variations in voltage in the battery and alternator - even though it may start the car fine, there still might be issues... do a quick search on the subject.

How old is your battery?

Skyline 02-01-2013 04:02 PM

#3 Tail light issues are a know probloem with these cars. There is a DIY fix, or you can buy new lights. Yours might be on the way to failing. Do a search for this issue.

Elvis 3.0 02-01-2013 04:17 PM

:iagree: on all points above- How long have you had the X?

if you haven't change out your battery it should be an easy swap.

As for the taillights - I have done and would recommend the solder method that is well documented on this site. It will take you about an hour. After years of toiling with replacing bulbs unnecessarily I finally did it last fall. No problems since.

Changing the battery and doing the solder fix on the brake lights shouldn't take more than $200 and three hours total ( at most)

mrothwell 02-01-2013 05:29 PM

Ok, I just read a few threads on battery issues, and checking the voltage thru the computer.

I read in one thread about registering the battery?? Why??? What does this accomplish, what is the problem of NOT registering the battery?? I've never heard of this before.

Skyline 02-01-2013 06:13 PM

Quote:

Originally Posted by mrothwell (Post 920197)
Ok, I just read a few threads on battery issues, and checking the voltage thru the computer.

I read in one thread about registering the battery?? Why??? What does this accomplish, what is the problem of NOT registering the battery?? I've never heard of this before.

Not necessary for your year.

TerminatorX5 02-01-2013 07:38 PM

on the newer ones the "registering" tells the charging computer and voltage regulator, when to "start" and "stop" charging and the other super high tech stuff...

the E53 was spared from that process


All times are GMT -4. The time now is 12:49 AM.

vBulletin, Copyright 2022, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.