Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E53) Forum (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/)
-   -   Help with a coolant leak (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/98404-help-coolant-leak.html)

X5only 10-03-2014 12:46 AM

What is the coolant level in the reservoir when the engine is cold? Is the end of the red float aligned with the upper edge of the filler opening? If not, you could be experiencing exactly what I went through with my X5 2005 4.4- over-pressurized cooling system due to coolant overfill. I replaced reservoir twice due to cracks causing leaks and coolant leaking from under the car when it sat for 3 or more days. Finally discovered I was overfilling the coolant (red float all the way up). Simply correcting the level fixed the leak and no more cracking reservoir.

70-k5 10-03-2014 02:18 AM

Coolant level is empty.. wish it was that simple.

garrett.fell 10-03-2014 08:29 AM

That's a bummer. Yes - the BMW "way" is very involved and involves a *lot* disassembly. I recall reviewing information on this at one time that suggested all german auto (the guys who make one of the collapsible pipe designs) did it for $2-3k. 5-7k just seems like too much $$$.


Sent from my iPhone using Tapatalk

70-k5 10-03-2014 04:13 PM

Thanks to all you guys who helped with input on this thread.
I talked to Freeman Motors in Portland, OR.

Their impression was that the Bimmerfix stint was the best option. They feel that it is as good as it gets for the cost. They did quote me $995 for the job which included the kit, new upper and lower radiator hoses assuming that they weren't replaced when the waterpump was done two years ago, and a waterpump gasket.

While they're at it they also quoted me:

Power steering hoses (leaking) $350
Thrust Rods (worn) $585
Outer CV Boot (ripped) $400

They're also going to reset my airbag light that has been on since I removed the front seats to install a stereo.
I have a good feeling about this shop, anybody with input on these repair charges feel free to chime in.

garrett.fell 10-03-2014 04:58 PM

The power steering hoses might only be leaking from the bottom of the reservoir. This is often the case. You can just cut the old clamps off with a Dremel and install your standard hose-clamp for a couple bucks. The hose stiffens after a while and leaks but if you install new clamps it'll squeeze the stiffened rubber enough to stop the leaking. Worked for me!




Sent from my iPhone using Tapatalk

70-k5 10-10-2014 01:48 PM

Well mechanic, 'bmw master technician' was impressed with the Bimmerfix kit. He said it worked well. They did get a laugh at the tube of special sealant which turned out to be juat a paper label taped over a tube of permatex.

They test drove a few times and say it's good to go.

drgeeforce 10-14-2014 02:37 PM

I had a number of issues with cooling system on all my BMWs, if it wasn't the expansion tank leaking, it was the radiator, or the hoses. The 200 expansion tank cap is probably too high, so I bought a 180 and most of my problems have gone away.

X5only 11-01-2014 09:32 PM

Quote:

Originally Posted by 70-k5 (Post 1012038)
Well mechanic, 'bmw master technician' was impressed with the Bimmerfix kit. He said it worked well. They did get a laugh at the tube of special sealant which turned out to be juat a paper label taped over a tube of permatex.

They test drove a few times and say it's good to go.

How is this fix holding up?

Bulk 11-03-2014 06:15 AM

I haven't read all of the posts here as I don't have time but as I recently fixed my coolant leak in my N62 and did my own coolant transfer pipe replacement (The ORO pipe).

Turns out it was my radiator. I replaced pipes, the coolant transfer and all o-rings, the expansion tank as it was really starting to shit me, it kept going so I did a real thorough inspection of every inch of the system and found a very small rust spot on a metal section at the top of the radiator. The problem is because it is a pressure system you fix one spot it just pops the next. The radiator was always the main culprit but once I had everything else buttoned up it gave me the signs that I could see.

Anyway radiator replaced and it all was fixed... hope that helps

talljames 03-12-2019 05:34 AM

Hi Guys, it seems the coolent expansion tank is a common problem. Recently I had my cooling system upgraded with new water pump, radiator, hoses. I started noticing I was loosing coolent. I have been topping up for a while and now it is mostly just water circulating so my temp is now up to 105 deg c instead of 90 deg C. I have a e53 2005 4.4i v8. Anyway, I have on many occassions put more water then what they say. I can now see signs of the coolent expansion tank or the pressure cap leaking. I assume the extra pressure should release the water somewhere (through the cap?). But, perhaps I have 1) damaged the coolent expansion tank; 2) created air pockets in the heater control valve (causing the inside cabin heating not to work); 3)caused a problem with the auxillary coolent pump.


All times are GMT -4. The time now is 08:41 PM.

vBulletin, Copyright 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.