Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E70) Forum (https://xoutpost.com/bmw-sav-forums/x5-e70-forum/)
-   -   Replaced AWD Module, shift issue. (https://xoutpost.com/bmw-sav-forums/x5-e70-forum/113673-replaced-awd-module-shift-issue.html)

Laecaon 09-11-2021 04:05 PM

Replaced AWD Module, shift issue.
 
Hi,

Car is an 08 X5 3.0

Quick history. Sun roof drain disconnected and flooded the rear of the car, standing water at the battery. AWD errors as water was splashing on the module. Fixed that and dried things out. Issue gone for 5 months. Then AWD issues came back intermittently. Finally diagnosed it as the module itself and ordered a used replacement on eBay. All errors are gone now.



So now that I have "fixed" it, I have another issue which I think is a result.

Most noticeable is that downshifts to 1st gear are rough, but also upshifts from 1st to 2nd arent the nicest. You slow down to a stop and at like 1or 2 mph it down shifts and its not really pleasant. I am thinking I probably need to recode it, or something like that.



I only replaced the module yesterday, and these issues were immediately after replacement.



-Replaced AWD module with a used unit
-Rough downshift to 1st, and upshift from 1st
-I have INPA/NCSExpert software


Any help would be much appreciated.

ard 09-12-2021 02:02 AM

what is the "BMW name" for this AWD module???


ANy codes or warning when you read it with INPA?

Laecaon 09-12-2021 03:45 AM

"Control Box, Transfer Unit"


27607606629.


It exists next to the battery. I should have probably added that this is an 08.


I will scan codes tomorrow. I thought about it and realized I didnt even try to remove any codes either.

smassey321 09-12-2021 09:25 AM

Can you feel the 1-2 2-1 shift when you shift manually while stopped? If so, it is probably the solenoids in the transmission.

https://www.ebay.com/itm/40274338853...kAAOSwdS1dJOQF

ard 09-12-2021 01:08 PM

Did that module need coding/reseting?

Laecaon 09-12-2021 04:26 PM

Quote:

Originally Posted by smassey321 (Post 1209520)
Can you feel the 1-2 2-1 shift when you shift manually while stopped? If so, it is probably the solenoids in the transmission.

https://www.ebay.com/itm/40274338853...kAAOSwdS1dJOQF


The vehicle only has 86k miles, but I did test this, and it was smooth, almost could not tell it was shifting.



Quote:

Originally Posted by ard (Post 1209525)
Did that module need coding/reseting?


This I do not know. Clearly being an identical part number and version number the hardware is the same, and the manufacturer date was only 3 months newer and being pulled from a 3.0si of the a similar year, I imagine the programming is good... but not necessarily any adaptations.









I did do a transmission adaptations reset. And I cleared the codes on the VTG and Parking brake. None came back immediately. Ill drive it again later today and check again.



But that said, the shifting is definitely better. Less noticeable, but still there. Im honestly thinking its something to do with the timing between the clutch solenoids firing in the Transfer case and transmission shifting.

ard 09-12-2021 07:13 PM

In the TIS, the official instructions say to "carry out programming/encoding" when 'removing and installing'


All times are GMT -4. The time now is 03:18 AM.

vBulletin, Copyright 2022, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.