Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E70) Forum (https://xoutpost.com/bmw-sav-forums/x5-e70-forum/)
-   -   Fuel Problem....suggestions welcome (https://xoutpost.com/bmw-sav-forums/x5-e70-forum/84561-fuel-problem-suggestions-welcome.html)

hwfrog 11-19-2011 06:23 PM

Fuel Problem....suggestions welcome
 
Totally stumpped! I have a 2008 X5 3.0, under warranty, dealer maintained with 40k on it. Love the car and it's perfect except for 1 annoying factor. I ran the fuel tank down until the light came on and it was showing about 26mi on the digital guage. I came to a stop light, not slow rolling but not super aggressive either, and the car shuddered, and died. It started right up and it did the same thing at the next light. I went to the gas station and filled it up and it only took about 21gallons of fuel. Let that tank run down until the light came on and same thing happened. I took it in to the dealer and replicated it for the master tech. They replaced both fuel sensors and figured all was good. Not so much. Out of curiosity, I let the next tank run down until the light and sure enough, same issue. Back to the dealer and this time they replaced an internal fuel line in the tank. So, let it run down again and same thing. Back to the dealer and this time they couldn't get it to replicate. I picked the car up, drove down the street and the first light I came to it happened again. Again, each time I fill up it will only take 21 - 21.7 gallons top. I'm pretty sure we have a 24 gallon tank. It started doing it with 26mi left, then 31 then 36 and last time it had 41. After this last time at the shop, I'm now getting 13-15mpg as opposed to the 16.8-17.5mpg I usually get around town.

Now, I realize what some are thinking, don't be cheap and fill your car up. That's not the point, the point is, is something's wrong. Anyone experience this and if so, what were the findings. At this point, any suggestions would help...

Thanks in advance

diesaroo 11-20-2011 01:54 PM

really?
 
Quote:

Originally Posted by hwfrog (Post 852510)
Totally stumpped! I have a 2008 X5 3.0, under warranty, dealer maintained with 40k on it. Love the car and it's perfect except for 1 annoying factor. I ran the fuel tank down until the light came on and it was showing about 26mi on the digital guage. I came to a stop light, not slow rolling but not super aggressive either, and the car shuddered, and died. It started right up and it did the same thing at the next light. I went to the gas station and filled it up and it only took about 21gallons of fuel. Let that tank run down until the light came on and same thing happened. I took it in to the dealer and replicated it for the master tech. They replaced both fuel sensors and figured all was good. Not so much. Out of curiosity, I let the next tank run down until the light and sure enough, same issue. Back to the dealer and this time they replaced an internal fuel line in the tank. So, let it run down again and same thing. Back to the dealer and this time they couldn't get it to replicate. I picked the car up, drove down the street and the first light I came to it happened again. Again, each time I fill up it will only take 21 - 21.7 gallons top. I'm pretty sure we have a 24 gallon tank. It started doing it with 26mi left, then 31 then 36 and last time it had 41. After this last time at the shop, I'm now getting 13-15mpg as opposed to the 16.8-17.5mpg I usually get around town.

Now, I realize what some are thinking, don't be cheap and fill your car up. That's not the point, the point is, is something's wrong. Anyone experience this and if so, what were the findings. At this point, any suggestions would help...

Thanks in advance

I do not know why your mileage would be dropping...water in gas? IIRC your tank holds 22.5 gallons not 24.

grudge 11-20-2011 02:25 PM

Replace your fuel filter. See what happens.


All times are GMT -4. The time now is 12:14 PM.

vBulletin, Copyright 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.