Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW Related Forums > Group Buys
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Closed Thread
 
LinkBack Thread Tools Display Modes
  #41  
Old 11-13-2006, 05:28 PM
cpatzer's Avatar
Member
 
Join Date: Aug 2006
Location: Seattle
Posts: 658
cpatzer is on a distinguished road
Just got mine. :-) Christmas came early for me this year!!!! I will let you all know how it sounds.

Side note: To those slackers who have not purchased theirs yet. GET a fricken move on! As they say s*&t or get of the pot.

Last edited by cpatzer; 11-13-2006 at 05:50 PM.

Sponsored Links

  #42  
Old 11-14-2006, 01:06 AM
cpatzer's Avatar
Member
 
Join Date: Aug 2006
Location: Seattle
Posts: 658
cpatzer is on a distinguished road
I have the sub sucessfully installed. The only real problem I had was threading the factory bolts into the sub enclosure as they seem to have some sort of residue left over from the manufacturing process. I just dug it out with a screw driver.The install notes mention that you should cut the retaining clips off of the padding on the back of the factory cover, these can easily be pulled off with a pair of pliers. You can also pull the plastic raisers off by twisting them with a pair of snub nose pliers instead of filing them off.

I did however run into one major problem. I can find NO PLACE AT ALL to put the amp. I purchased the A1200 in hopes that it would be small enough. I guess that was too much to hope for. Maybe I purchased too many options when I purchased the car.

Does anybody have any ideas? I would really, really like to have the amp hidden.

Thanks,

Christian
  #43  
Old 11-14-2006, 01:34 AM
Member
 
Join Date: Apr 2006
Location: Los Angeles
Posts: 46
Ivan22 is on a distinguished road
AMP Location

I will tell you what I will be doing for mine. I plan on making an article, but in the mean time, here is a quick and dirty. Since I have to wait for my Stealthbox, I began the work on the amp wiring.

Remove your spare tire cover. There are black plastic floor fillers to the left of the spare tire. The right side of the spare tire has them also, but they are neat emergency tool holders.

Once you remove the black plastic (bunch of dead space), you will see a rectangular metal bracket welded to the body of the car. Use a torch or a plasma cutter to remove that useless support bracket. Your amp will end up supporting that area. But realistically, how often will you be transporting bricks in your trunk to need all the added support?

That will be my location for the amp. It is very close to the factory amp, near the battery, near the ground terminal of the battery to the frame, and near the sub location. Your system will benefit from short cables and no loss in power. Remeber, current is like water through a hose, the shorter and bigger the hose, the better the flow.

I also placed a half farad capacitor right in front of the fuse terminal (the plastic box with a bunch of red wires distributed from the battery).

On top of all, it is hidden under your floor!

I will post pictures as soon as I am done.
  #44  
Old 11-14-2006, 10:57 AM
chusteveb's Avatar
Member
 
Join Date: May 2006
Location: Oklahoma City
Posts: 220
chusteveb is on a distinguished road
Wow, ok! So I'm glad to hear I'm not the only person who had a dificult time trying to clean out the threads in order to get the factory bolts to fit into the stealth box. Also, I too used plyers and twisted off the plastic on the cover.

As to amp placement, did you see where I installed my JL A2150?



It works good for me! Good luck and lets hear of any other suggestions for amp placement!

I've had my stealth box up and playing now for a couple of weeks, I love it!

Quote:
Originally Posted by cpatzer
I have the sub sucessfully installed. The only real problem I had was threading the factory bolts into the sub enclosure as they seem to have some sort of residue left over from the manufacturing process. I just dug it out with a screw driver.The install notes mention that you should cut the retaining clips off of the padding on the back of the factory cover, these can easily be pulled off with a pair of pliers. You can also pull the plastic raisers off by twisting them with a pair of snub nose pliers instead of filing them off.

I did however run into one major problem. I can find NO PLACE AT ALL to put the amp. I purchased the A1200 in hopes that it would be small enough. I guess that was too much to hope for. Maybe I purchased too many options when I purchased the car.

Does anybody have any ideas? I would really, really like to have the amp hidden.

Thanks,

Christian
  #45  
Old 11-14-2006, 10:58 AM
chusteveb's Avatar
Member
 
Join Date: May 2006
Location: Oklahoma City
Posts: 220
chusteveb is on a distinguished road
here's an link to my amp install:

http://www.xoutpost.com/x5-e53-forum/...ound-clip.html
  #46  
Old 11-14-2006, 12:03 PM
TeXfive's Avatar
Member
 
Join Date: May 2006
Location: Reunion Island (France)
Posts: 44
TeXfive is on a distinguished road
I was wondering why is this GB not available for X5ers outside US ?

I'm interested in buying this stealthbox so if this "no exception" rule can be broken... I'm in for one !
  #47  
Old 11-14-2006, 01:03 PM
racerboydrew's Avatar
Member
 
Join Date: Aug 2006
Location: Colorado
Posts: 53
racerboydrew is on a distinguished road
Are there any forms remaining? If so, I'm in.
__________________
  #48  
Old 11-14-2006, 01:26 PM
cue03's Avatar
Member
 
Join Date: Aug 2006
Location: South Florida
Posts: 493
cue03 is on a distinguished road
I WANT IN!! PLEASE GIVE ME AN OPPORTUNITY..... After listening to my 4.8is at louder volumes today... man it is a must to get rid of that wimpy sub setup.

Last edited by cue03; 11-14-2006 at 05:08 PM.
  #49  
Old 11-14-2006, 01:27 PM
cpatzer's Avatar
Member
 
Join Date: Aug 2006
Location: Seattle
Posts: 658
cpatzer is on a distinguished road
Chusteveb,

Thanks for the link but I am really not into hammering anything in my baby, or cutting with a plasma cutter for that matter. I will probably end up building an amp rack or buying a really small amplifier somewhere else.

Also I don't even know if that would work, as my X5 does not have the sliding cargo hold.
  #50  
Old 11-14-2006, 04:32 PM
cue03's Avatar
Member
 
Join Date: Aug 2006
Location: South Florida
Posts: 493
cue03 is on a distinguished road
Ivan,

In that attached picture in the first post of this thread, is the rear section cover where the speaker is really see through or is that photochop working there?

I am wondering what others will do for sitting behind such a thick panel.

Also is this solution completely plug and play for removing the old sub combo and putting in this combo? I am hoping there is no heavy lifting like finding wires/connectors, following setups that are super complicated etc.

Lastly, i live very close to JL in fort lauderdale (about 20 min from me). Can I get them to do the install for me?

Curtis

Last edited by cue03; 11-14-2006 at 04:59 PM.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 03:29 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.