Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X3 (E83) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-12-2018, 11:03 PM
Member
 
Join Date: Feb 2018
Location: Los Angeles
Posts: 1
nosupfoyu is on a distinguished road
Just bought used X3 3.0i - Help with diagnosing 2 noises?

Couldn't pass up on buying a 2005 X3 with 86k yesterday. Couple of noises I'm hearing, hope you guys can help me figure out what needs work:

-Engine chirping sound on cold start, emphasized when turning steering wheel. Potential PS fluid or belt/pulley/tensioner issue? (video: Chirping, squeaking sound )

-Thumping/clunking feeling when braking abruptly, low or high speeds. I don't think it's the brake system. Potential control arm bushings gone? (sorry no video here!)

Let me know if I need to include more details to pin-point issues?

Thanks for your help.
Reply With Quote

Sponsored Links

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 04:32 AM.
vBulletin, Copyright 2018, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.