Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X3 (E83) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2005, 01:22 PM
Member
 
Join Date: Mar 2005
Location: X5world
Posts: 1
gtonezX5 is on a distinguished road
X3 stereo amplifier problems HELP

Hey everyone, i have an x5 and had my local stereo shop wire a amplifier and sub off of it , it sounds great. But now that my wife has an x3, i had them wire a couple infinity basslinks with a soundgate adapter off of the stock amp....it sounds like GARBAGE. On the radio some songs will have normal bass but then other songs on the same station will come in with huge warbled bass, even when the dj is just talking. The stereo shop says its because of the ODD stock x3 amplifer. Does anyone know of a fix for this situation?? I'd pay for it, cause my wife is stuck in a 3 yr lease and loves clean crisp bass, which shes not getting.

thanx gtone
Reply With Quote

Sponsored Links

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 11:37 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.