Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-11-2016, 12:30 PM
Member
 
Join Date: Feb 2016
Location: Vancouver
Posts: 2
alfiem3 is on a distinguished road
Exclamation Please help! 2A84 Inlet Vanos 2 and other codes

Hello members of the Xoutpost!, I have always been a BMW enthusiast, my current car collection includes a 850i, E46 M3, 320i, S52 M coupe and most recently this E53 X5

I bought the car from the auction and although it is in pretty good condition, there were a couple of power train related issues.

For the most part I fixed the stupid plastic transfer case gear, changed all 4 pads and got rid of all the lights except the Check engine light.

When diagnosed with DIS, this are the codes I was getting:

2A84: Inlet Vanos 2
29EE: fuel mixture adaptation
29F0: fuel mixture adaptation
29F4: catalytic converter Error
2C24: Oxygen sensors before catalytic converter mixed up

I was wondering if the 2A84 will cause the rest of the codes except for the mixed up sensors lol?

2A84 is my mayor concern, as the car has a rough idle, and sometimes lack of power, It`s specially worse in the morning and it gets better as it warms up.

Things I`ve done to troubleshoot the problem

*Swapped Solenoids from Bank 1 to Bank 2 and vice versa
*Checked the resistance from the Camshaft position sensor
The CPS with the long tail (Bank 2) reads: 1.315 Ohms
The CPS without the tail (Bank 1) reads: 1.559 Ohms
*Performed Ram Back up procedure (This fixed the problem for a bit and then it gets worse as the time goes by)

On the DIS, I can see all the VANOS Values constantly updating except for the:
VANOS adaptation Inlet Cyl 1-4
VANOS adaptation Inlet Cyl 5-8
They are both stucked at 127

Could this be a Camshaft position sensor problem?, what other things Should I try?

Thank you in advance!

Pictures attached:
https://drive.google.com/folderview?...Ws&usp=sharing

Last edited by alfiem3; 02-11-2016 at 12:35 PM. Reason: Broken picture link
Reply With Quote

Sponsored Links

  #2  
Old 02-13-2016, 04:36 PM
Member
 
Join Date: Feb 2016
Location: Vancouver
Posts: 2
alfiem3 is on a distinguished road
Saturday bump
Reply With Quote
Reply

Bookmarks

Tags
2a84, camshaft position sensor, e53, vanos

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 09:07 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.