Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2017, 05:30 AM
four.8is's Avatar
Member
 
Join Date: Feb 2014
Location: Seattle
Posts: 934
four.8is is on a distinguished road
Knock sensor N62

hey guys, the last two weeks I had the CEL illuminate intermittently , 2 days on, 2 days off type of thing...

Pulled out DIS and checked the code. P1327: Knock sensor signal 2.....does that mean bank 2, driver's side? check out pic below..

If im gonna go through the trouble of removing the intake manifold, should I replace both sensors?

New intake gaskets for sure, but how about injectors o-rings? are they mandatory to replace?...btw, ive got 145k miles.

Any other tips from others that have done the job before?

Thanks!
__________________
2006 X5 4.8is LeMans Blue / creambeige interior
Prod.date: 2006-06-21
Reply With Quote

Sponsored Links

  #2  
Old 03-18-2017, 03:49 PM
four.8is's Avatar
Member
 
Join Date: Feb 2014
Location: Seattle
Posts: 934
four.8is is on a distinguished road
No one has replaced one of these before?
__________________
2006 X5 4.8is LeMans Blue / creambeige interior
Prod.date: 2006-06-21
Reply With Quote
  #3  
Old 03-18-2017, 05:51 PM
Premier Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 2,328
crystalworks is on a distinguished road
When I started reading I was being optimistic for you and hoping you just had a tank of bad gas or something that would trip the knock sensor... but it looks like you actually have an intermittent open circuit at the sensor or plug.

Sorry no info for you on accessing/replacing them.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote
  #4  
Old 03-18-2017, 06:03 PM
four.8is's Avatar
Member
 
Join Date: Feb 2014
Location: Seattle
Posts: 934
four.8is is on a distinguished road
Yeah haven't found much info on this either...
I guess I'll just order both sensors for peace of mind and have at it...
__________________
2006 X5 4.8is LeMans Blue / creambeige interior
Prod.date: 2006-06-21
Reply With Quote
  #5  
Old 03-18-2017, 06:46 PM
Member
 
Join Date: Jun 2015
Location: Southlake, Texas
Posts: 1,951
X53Jay4.8is is on a distinguished road
Quote:
Originally Posted by four.8is View Post
Yeah haven't found much info on this either...
I guess I'll just order both sensors for peace of mind and have at it...
Yes you should change both knock sensors while you are in there. I must admit these are one of those items that rarely goes. I bet when you rip it down it may be evident why the knock sensor failed. The ones that I have seen are pretty corroded.
Reply With Quote
  #6  
Old 03-19-2017, 06:27 PM
four.8is's Avatar
Member
 
Join Date: Feb 2014
Location: Seattle
Posts: 934
four.8is is on a distinguished road
you know, I haven't found too much info on N62 having this problem so yeah the ones that go bad are pretty isolated cases. Digging back in some older pictures I took while searching in DIS I did find the exact same code showing up last September...
So ever since it has not come back but now its pretty persistent..

Ill go ahead and replace them, only thing I fear when I take the intake off is to find out the coolant pipe is leaking...that would be the end of it.
__________________
2006 X5 4.8is LeMans Blue / creambeige interior
Prod.date: 2006-06-21
Reply With Quote
  #7  
Old 03-20-2017, 06:58 PM
Member
 
Join Date: Jun 2015
Location: Southlake, Texas
Posts: 1,951
X53Jay4.8is is on a distinguished road
Quote:
Originally Posted by four.8is View Post
you know, I haven't found too much info on N62 having this problem so yeah the ones that go bad are pretty isolated cases. Digging back in some older pictures I took while searching in DIS I did find the exact same code showing up last September...
So ever since it has not come back but now its pretty persistent..

Ill go ahead and replace them, only thing I fear when I take the intake off is to find out the coolant pipe is leaking...that would be the end of it.
Great time to address the coolant pipe if it has not been addressed.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 09:03 AM.
vBulletin, Copyright 2017, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.