Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-14-2018, 12:19 AM
Member
 
Join Date: Mar 2017
Location: Los Angeles
Posts: 105
Maruzo is on a distinguished road
Issue with newly replaced nav screen for 03 e53

Question on the oem nav monitor:

I just replaced the monitor with a new sharp unit from ebay. The BMW logo showed up when I plugged in the unit, but the unit won’t power on when I press th power switch.

Am I missing something here? Maybe it needs a radio code first? Or is it because I also had the instrument cluster out (just sent it out fo pixel repair), and when the system boots up With key in ignition, it searches for any missing components (such as the instrument cluster) and shuts down the radio as a result?
__________________
2003 X5 4.6is Estoril Blue, acquired March 2018
2006 330i Sports 6 MT Sparkling Graphite daily driver
2010 535xi 6 MT Barbera Red
Reply With Quote

Sponsored Links

  #2  
Old 04-15-2018, 01:26 AM
brucemillar's Avatar
Member
 
Join Date: Mar 2008
Location: United Kingdom
Posts: 218
brucemillar is on a distinguished road
I can only tell you that when I replaced my damaged screen with one from ebay, it was a straight swap and started up fine with zero tweaking required.

NB. I did not have anything else disconnected from the car at the time.
Reply With Quote
  #3  
Old 04-16-2018, 02:48 AM
Awntchi's Avatar
Member
 
Join Date: Nov 2015
Location: Norway
Posts: 380
Awntchi is on a distinguished road
Quote:
Originally Posted by Maruzo View Post
Question on the oem nav monitor:

I just replaced the monitor with a new sharp unit from ebay. The BMW logo showed up when I plugged in the unit, but the unit won’t power on when I press th power switch.

Am I missing something here? Maybe it needs a radio code first? Or is it because I also had the instrument cluster out (just sent it out fo pixel repair), and when the system boots up With key in ignition, it searches for any missing components (such as the instrument cluster) and shuts down the radio as a result?
What happens after the logo shows? Do you get the menu up etc.?

Sent from my SM-G900F using Tapatalk
__________________
BMW X5 E53, 4.8iS - 2005
Professional Stereo/Nav with DSP (modified BM54 module) - Converted to Eonon GA5166X with Reverse cam
4-Corner Air Suspension - Converted to BC Coilovers
Reply With Quote
  #4  
Old 04-16-2018, 02:58 AM
Member
 
Join Date: Mar 2017
Location: Los Angeles
Posts: 105
Maruzo is on a distinguished road
I didn’t get anything after the logo screen. The screen jue went dark after that.
__________________
2003 X5 4.6is Estoril Blue, acquired March 2018
2006 330i Sports 6 MT Sparkling Graphite daily driver
2010 535xi 6 MT Barbera Red
Reply With Quote
  #5  
Old 04-16-2018, 04:09 AM
Awntchi's Avatar
Member
 
Join Date: Nov 2015
Location: Norway
Posts: 380
Awntchi is on a distinguished road
Ok, it's strange that it shows the logo (meaning it gets power) and then shuts off. There is a link between the cluster and Nav like when setting time, checking consumption etc so it might explain the issue but that's just a guess.

Sent from my SM-G900F using Tapatalk
__________________
BMW X5 E53, 4.8iS - 2005
Professional Stereo/Nav with DSP (modified BM54 module) - Converted to Eonon GA5166X with Reverse cam
4-Corner Air Suspension - Converted to BC Coilovers
Reply With Quote
  #6  
Old 04-16-2018, 04:58 PM
Member
 
Join Date: Jun 2017
Location: Australia
Posts: 83
FourPointEight-is is on a distinguished road
Shine a bright light on the display, see if you can see anything? Maybe the back-light is DOA on your new unit, runs for a split second then shuts off (which is why you see the logo briefly then nothing).
Reply With Quote
  #7  
Old 04-17-2018, 09:36 AM
Qsilver7's Avatar
Member
 
Join Date: Oct 2012
Location: Indiana, USA
Posts: 3,045
Qsilver7 is on a distinguished road


__________________
(if my grammar, spelling, sentence structure is wacky...it's my dang bluetooth keyboard)

{BMW CCA Member #191509 - (for more info see: www.bmwcca.org)}
  • 2006 e53 X5 4.4i (12/05 build date) Sterling Gray exterior/Schwarz (black) interior
  • 1997 e38 740iL (3/97 build date) Arctic Silver exterior/Gray interior
  • 1999 e39 540iT (sold) Orient Blue
  • 1995 e34 525iT (sold) Alpine White
  • 1991 e32 735iL (sold) Schwarz (black)
  • 1985 e30 325e (sold) Bronzit
Reply With Quote
  #8  
Old 04-28-2018, 10:21 PM
Member
 
Join Date: Mar 2017
Location: Los Angeles
Posts: 105
Maruzo is on a distinguished road
Quote:
Originally Posted by FourPointEight-is View Post
Shine a bright light on the display, see if you can see anything? Maybe the back-light is DOA on your new unit, runs for a split second then shuts off (which is why you see the logo briefly then nothing).
A quick update on my nav screen issue. I just got the repaired instrument cluster today and installed it promptly.

After hooking up the panel, I proceeded to plug in the nav monitor. This time, the nav screen fired up without any issues.

Apparently the absence of the instrument panel disabled the nav screen as well.

The only drawback I can see is the monitor seems hard to view at the current angel.

Is it possible that I need to purchase another screen so the viewing angle works better?

Any ideas?
__________________
2003 X5 4.6is Estoril Blue, acquired March 2018
2006 330i Sports 6 MT Sparkling Graphite daily driver
2010 535xi 6 MT Barbera Red

Last edited by Maruzo; 05-21-2018 at 11:00 PM.
Reply With Quote
  #9  
Old 04-29-2018, 11:00 AM
Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 2,626
crystalworks is on a distinguished road
They ALWAYS send an E39 replacement screen when you purchase a replacement. I had the same thing happen to me when I did mine. The E39 and E53 have different viewing angles... They sent me 2 screens, both did the same thing so I gave up trying to get an E53 specific replacement.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote
  #10  
Old 06-24-2018, 09:33 PM
Member
 
Join Date: Mar 2017
Location: Los Angeles
Posts: 105
Maruzo is on a distinguished road
Quote:
Originally Posted by crystalworks View Post
They ALWAYS send an E39 replacement screen when you purchase a replacement. I had the same thing happen to me when I did mine. The E39 and E53 have different viewing angles... They sent me 2 screens, both did the same thing so I gave up trying to get an E53 specific replacement.
Got a replacement screen with the 51u model number and installed it today. The screen is much more legible than before.
__________________
2003 X5 4.6is Estoril Blue, acquired March 2018
2006 330i Sports 6 MT Sparkling Graphite daily driver
2010 535xi 6 MT Barbera Red
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 07:48 AM.
vBulletin, Copyright 2018, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.