Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-09-2019, 06:34 PM
740ilDuke's Avatar
Member
 
Join Date: Oct 2011
Location: Greenville, NC
Posts: 381
740ilDuke is on a distinguished road
2002 4.6is - A few codes day 2 on the road

X5 sat mostly last 10 months.

Codes:

4 Lambda Sensor Heater Post Cat Bank 2

20 Lambda Probe 2 rear cat

23 Lambda sensor ageing h cat bank 2

(Are 4,20,23 the same sensor)

189 DMTL Module - Pretty sure the pump is bad, 2nd time itís thrown this code. (reset yesterday)

26 LR-Adaptation multiple Area 1
27 LR-Adaptation multiple (Bank 2)

No idea what 26 & 27 are..?



Filled with Shell 93 & Seafoam.


Sent from my iPhone using Tapatalk
__________________
740iLDUKE
01' DINAN 7 S62 Swap - Stratus Grau
(1587 produced in SG 440)
02' 4.6is DINAN X5 S2 Supercharged
833/3258 produced | 1/27 Dinan X5's
Greenville, NC
Reply With Quote

Sponsored Links

  #2  
Old 04-11-2019, 09:24 PM
740ilDuke's Avatar
Member
 
Join Date: Oct 2011
Location: Greenville, NC
Posts: 381
740ilDuke is on a distinguished road
Cleared codes 2 days ago. Drove a few cycles, light cut on again last night.

4/11/19 Codes

20- Lambda probe 2 rear cat

4 - 02 sensor heater rear kat bank 2

81 - secondary air system bank 2

27 - LR adaptation area1 bank 2

23 - Lambda sensor ageing hcat bank 2

Where should I start?
__________________
740iLDUKE
01' DINAN 7 S62 Swap - Stratus Grau
(1587 produced in SG 440)
02' 4.6is DINAN X5 S2 Supercharged
833/3258 produced | 1/27 Dinan X5's
Greenville, NC
Reply With Quote
  #3  
Old 04-11-2019, 10:40 PM
Member
 
Join Date: Oct 2011
Location: NYC
Posts: 4,547
SlickGT1 is on a distinguished road
I would start with the air pump. And oxygen sensors.

Does the 4.6 have the valvetronic, that might be 27?
__________________
2006 4.8is, Black on White.

"The older we grow the greater becomes our wonder at how much ignorance one can contain without bursting one's clothes." - Mark Twain

Unlock OBC post 5
Reply With Quote
  #4  
Old 04-11-2019, 10:56 PM
740ilDuke's Avatar
Member
 
Join Date: Oct 2011
Location: Greenville, NC
Posts: 381
740ilDuke is on a distinguished road
Quote:
Originally Posted by SlickGT1 View Post
I would start with the air pump. And oxygen sensors.

Does the 4.6 have the valvetronic, that might be 27?
Secondary air pump works great. Or sounds like it does.

Valvetronic began on the N62 thankfully.

Ill dig into the sensors.

Thanks!!

Some history - it sat for about 10 months. Supercharger had oil blow-by that was remedied with a rebuild. Runs great off and on. Seafoam in the gas tank and tonight I soaked the throttle body/intake in spray seafoam and got a load of smoke out of driver side bank exhaust. Wondering if some of this is from the oil being misted through the throttle body.
__________________
740iLDUKE
01' DINAN 7 S62 Swap - Stratus Grau
(1587 produced in SG 440)
02' 4.6is DINAN X5 S2 Supercharged
833/3258 produced | 1/27 Dinan X5's
Greenville, NC
Reply With Quote
  #5  
Old 04-12-2019, 03:12 PM
Member
 
Join Date: Jan 2016
Location: Michigan
Posts: 49
ahlem is on a distinguished road
Some of the plastic hoses get pretty crispy at this age.
I'd try a smoke test if you can get at a unit.
I found a video on the Bavauto site that may still be around that showed the replacement of the vacuum pump and where those hoses are.
My similar problem was solved by changing a $40 hose.
Reply With Quote
  #6  
Old 04-12-2019, 07:27 PM
Member
 
Join Date: Oct 2011
Location: NYC
Posts: 4,547
SlickGT1 is on a distinguished road
If you were burning oil it could have deff destroyed your o2, and cats.

Isnít the m62 secondairy air pump only for getting up to operating temp, then it shuts off? I havenít messed with an m62 in a long time now. I forget. Anyway if it isnít necessary for when engine is at operating temp, then then that means your first 02 is monitoring it.

Found it. Yea if you feel the SAP is kicking in, and working, then go with the first 02. Probably shot from oil cookage.

https://bimmertips.com/what-does-the...y-air-pump-do/
__________________
2006 4.8is, Black on White.

"The older we grow the greater becomes our wonder at how much ignorance one can contain without bursting one's clothes." - Mark Twain

Unlock OBC post 5
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 05:54 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.