Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-06-2019, 12:35 PM
Member
 
Join Date: Sep 2010
Location: AZ
Posts: 34
rwm514 is on a distinguished road
No heat after coolant expansion replacement M54

So as the title says, I recently replaced my GF's coolant expansion tank. When I refilled the coolant, I noticed that it wouldn't take additional coolant once I turned on the heat inside the car and ran the fan on low. I tried running it to warm about 10 times to see if it would drop coolant level but it never did and still won't blow warm air. Any ideas?

Background: It had a slow leak from a crack in the expansion tank and actually ran hot on the gauge cluster. She shut it down immediately and had it towed to my house. I believe it was pretty low on coolant which caused the high temp. I also replaced the main thermostat, the thermostat in the bottom of the expansion tank, a new sensor in the tank and the other sensor in the lower radiator hose as well as a new cap on the tank.
__________________
2002 4.6is
Reply With Quote

Sponsored Links

  #2  
Old 08-06-2019, 05:21 PM
wpoll's Avatar
Member
 
Join Date: Sep 2015
Location: South Island, New Zealand
Posts: 2,631
wpoll will become famous soon enough
Did you bleed the coolant using the proper method? Filling the system with ignition on but engine not running? This runs the electric aux water pump - you can see the small stream of coolant coming back into the top of the expansion tanks when its getting full.
__________________
Wayne
2005 BMW X5 3.0d (b 02/05)
2001 BMW F650GS Dakar (b 06/01)
Reply With Quote
  #3  
Old 08-06-2019, 06:01 PM
Member
 
Join Date: Sep 2010
Location: AZ
Posts: 34
rwm514 is on a distinguished road
Yes. That's how I did it but the level didn't drop at all when I put the ignition in position two and turned on the heater.
__________________
2002 4.6is
Reply With Quote
  #4  
Old 08-06-2019, 06:29 PM
wpoll's Avatar
Member
 
Join Date: Sep 2015
Location: South Island, New Zealand
Posts: 2,631
wpoll will become famous soon enough
Quote:
Originally Posted by rwm514 View Post
Yes. That's how I did it but the level didn't drop at all when I put the ignition in position two and turned on the heater.
Did you hear the aux water pump running or see the small stream or returning coolant? Maybe the aux water pump has failed.

There's also a couple of bleed screws you need to open but that's before you turn on the ignition - when you're doing the initial fill. Cover the alternator with a plastic bag to avoid screwing it with coolant....
__________________
Wayne
2005 BMW X5 3.0d (b 02/05)
2001 BMW F650GS Dakar (b 06/01)
Reply With Quote
  #5  
Old 08-07-2019, 06:08 AM
Member
 
Join Date: Aug 2017
Location: ny
Posts: 40
tttomttt is on a distinguished road
+1 on the aux water pump as that hung me up as well in the past. Easy to replace once you remove the air cleaner box.
Reply With Quote
  #6  
Old 08-07-2019, 03:59 PM
Member
 
Join Date: Sep 2010
Location: AZ
Posts: 34
rwm514 is on a distinguished road
Ok I'll do some research and see if I can test the aux water pump. Thx!
__________________
2002 4.6is
Reply With Quote
  #7  
Old 08-07-2019, 05:48 PM
Member
 
Join Date: Jul 2016
Location: Menlo Park, CA
Posts: 969
Fifty150hs is on a distinguished road
Quote:
Originally Posted by rwm514 View Post
Ok I'll do some research and see if I can test the aux water pump. Thx!
I had my aux pump go out as well. It's simple to replace, but pricey.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 07:01 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.