Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-15-2021, 06:12 PM
Member
 
Join Date: Dec 2020
Location: Kent
Posts: 7
Gary1508 is on a distinguished road
Head scratcher

Hi guys, I have a 2002 e53 with several issues due to the previous owner being an utter tool, I'm now having an issue with stereo system I was driving along happily listening to music then got an awful crackle and it died, the volume sometimes comes back on then crackles off again then I sometimes get no orange light on the head unit or I get popping and white noise so for 2 weeks now I've had silence in the car and I'm non the wiser please tell me someone has a solution
Reply With Quote

Sponsored Links

  #2  
Old 02-15-2021, 08:15 PM
Premier Member
 
Join Date: Feb 2010
Location: Northeast, USA
Posts: 122
rwilson is on a distinguished road
I get the same cracking/static noise when I use the rear window defroster.

turn off the defroster and the radio comes in loud and clear

also last week the radio would not turn on. If finally began to work again
once the interior warmed up. it was -6 degree F that morning

this probably is not your issue but thought I would send it along anyway

Rich
__________________
Rich Wilson
Reply With Quote
  #3  
Old 02-15-2021, 08:29 PM
wpoll's Avatar
Member
 
Join Date: Sep 2015
Location: South Island, New Zealand
Posts: 3,616
wpoll will become famous soon enough
Lots of possible causes here - but let's start with what stereo is in the car - an OEM CD Player with MID unit? Basic six-speaker system or 12-speaker system? Or maybe it has a Nav screen? Does it's has DSP or not?

So many options... ;-)
__________________
Wayne
2005 BMW X5 3.0d (b 02/05)
2001 BMW F650GS Dakar (b 06/01)

Last edited by wpoll; 02-16-2021 at 01:02 AM.
Reply With Quote
  #4  
Old 02-16-2021, 05:09 AM
Member
 
Join Date: Dec 2020
Location: Kent
Posts: 7
Gary1508 is on a distinguished road
Basic 6 speaker non dsp with nav, TV and CD changer
Reply With Quote
  #5  
Old 02-16-2021, 05:35 AM
wpoll's Avatar
Member
 
Join Date: Sep 2015
Location: South Island, New Zealand
Posts: 3,616
wpoll will become famous soon enough
Quote:
Originally Posted by Gary1508 View Post
Basic 6 speaker non dsp with nav, TV and CD changer
In that case the receiver/amplifier is in the boot/trunk, next to the battery.



Check for water damage....
__________________
Wayne
2005 BMW X5 3.0d (b 02/05)
2001 BMW F650GS Dakar (b 06/01)
Reply With Quote
  #6  
Old 02-16-2021, 05:42 AM
Member
 
Join Date: Dec 2020
Location: Kent
Posts: 7
Gary1508 is on a distinguished road
Done that only water I found in boot was in the right compartment due to light seal failure no other water
Reply With Quote
  #7  
Old 02-16-2021, 06:00 AM
wpoll's Avatar
Member
 
Join Date: Sep 2015
Location: South Island, New Zealand
Posts: 3,616
wpoll will become famous soon enough
Quote:
Originally Posted by Gary1508 View Post
Done that only water I found in boot was in the right compartment due to light seal failure no other water
OK, to save time, please tell us what else have you checked? Fuses, wiring, etc.

No sound on radio only, or all audio sources? Nav system still working?
__________________
Wayne
2005 BMW X5 3.0d (b 02/05)
2001 BMW F650GS Dakar (b 06/01)
Reply With Quote
  #8  
Old 02-16-2021, 06:06 AM
Member
 
Join Date: Dec 2020
Location: Kent
Posts: 7
Gary1508 is on a distinguished road
Nav system hasn't worked since Ive had the car, TV module is analogue so never worked, I've checked the fuses, checked connections both ends, the screen still shows trip computer and sometimes if I push the on button I get the orange light and station info but no sound on any source, it then turns itself off, the only thing I've noticed is a blue plug with round pins in the right hand compartment got wet from where it was leaking not sure if that's anything to do with the stereo
Reply With Quote
  #9  
Old 02-17-2021, 01:53 PM
Member
 
Join Date: Nov 2018
Location: Canada
Posts: 270
c-bass is on a distinguished road
I'm my experience crackling has usually been related to a faulty connection. At this age it could possibly be something not making a good connection on an internal solder joint or something along those lines if everything looks proper.
Reply With Quote
  #10  
Old 02-19-2021, 06:09 PM
Member
 
Join Date: Dec 2020
Location: Kent
Posts: 7
Gary1508 is on a distinguished road
Well I found the issue with the stereo, I had a proper inspection of the module and could smell the essence of burning so opened her up and there is melted wires and transformers, so new aftermarket stereo on the way.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 09:25 PM.
vBulletin, Copyright 2021, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.