Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #21  
Old 09-27-2021, 04:47 PM
crystalworks's Avatar
Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 5,796
crystalworks is on a distinguished road
Check another thing off the list then...

I'm left with outlier suggestions. You have rodents that might have damaged harnesses leading to the ECU box in the engine bay? Checked fuses in the 3 different fuse boxes?

Maybe your DME failed? It's not common, but not unheard of either. You could check the electronics box it's housed in for corrosion.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote

Sponsored Links

  #22  
Old 09-27-2021, 05:55 PM
Member
 
Join Date: Oct 2018
Location: Atlanta
Posts: 329
Oldmactech is on a distinguished road
Will do. This car lives outdoors soÖ..Mebbe.


Sent from my iPad using Tapatalk
Reply With Quote
  #23  
Old 09-27-2021, 08:13 PM
Premier Member
 
Join Date: May 2020
Location: Palm Springs, CA
Posts: 207
PalmSpringsE534.6 is on a distinguished road
Is your ABS cable still disconnected? If not, disconnect and clear codes and see if it will stay out of failsafe. I know you disco'd it...but if you didn't clear the codes after disconnecting it...the ABS can still interfere. I'm the guy who had the 4.6 that would go into transfailsafe at 71 mph (and reproducible). I chased gremlins for almost a month until I looked at the Car Area Network diagram and realized the ABS and EGS could speak via the CANbus and DME. I pulled the ABS and cleared the codes and no more Trans Failsafe. Sent my ABS out for repair and all was well once I reinstalled it. Just my experience and would suggest you at least try it out. Best of luck to you!
__________________
2003 E53 4.6is, titanium silver, black Nappa interior
Reply With Quote
  #24  
Old 09-28-2021, 09:33 AM
Member
 
Join Date: Oct 2018
Location: Atlanta
Posts: 329
Oldmactech is on a distinguished road
Dreaded trans. Failsafe prog.

Thanks, yes I did disconnect for a bit. Iím not sure how to clear the ABS code, is that through the dash diagnostics? My cheap scanner doesnít have that ability I donít think. Creator 310+.

I do notice that when I turn the ignition key the brake pedal slumps noticeably more than it used to so you are probably on to something.

Is it the electronic part of the ABS needs rebuilding of the whole damn thing?

Sent from my iPad using Tapatalk
Reply With Quote
  #25  
Old 09-28-2021, 09:36 AM
Premier Member
 
Join Date: May 2020
Location: Palm Springs, CA
Posts: 207
PalmSpringsE534.6 is on a distinguished road
Quote:
Originally Posted by Oldmactech View Post
Thanks, yes I did disconnect for a bit. Iím not sure how to clear the ABS code, is that through the dash diagnostics? My cheap scanner doesnít have that ability I donít think. Creator 310+.


Sent from my iPad using Tapatalk
I'm not familiar with that scanner so you'll have to dig in on that. If you don't clear the codes after the disconnection of the ABS, you won't really be able to see the result and determine if the ABS is part of the cause.

I'd highly recommend you purchase a Foxwell NT510/520/530 scanner if you are going to be diagnosing your X5....or install INPA on a Windows 10 laptop which will allow you to scan and to clear as well.
__________________
2003 E53 4.6is, titanium silver, black Nappa interior
Reply With Quote
  #26  
Old 09-28-2021, 10:39 AM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 8,507
andrewwynn will become famous soon enough
The c 310 from my understanding is a capable scanner, but finding the correct submenu just like with foxwell can be a challenge
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #27  
Old 09-30-2021, 11:59 AM
Member
 
Join Date: Oct 2018
Location: Atlanta
Posts: 329
Oldmactech is on a distinguished road
Ok, while waiting on parts I had a chance to test some of the fuses and all I tested were fine. These were in the glove box.

5 Alternator
9 Srs
46 transfer case
51 ABS
54 EGS
55 ABS
63 ABS

Oddly, fuse 54 was completely missing? I replaced the 15a fuse but with no effect. Iíve have owned and driven this thing for 3 yrs with no problems but Iím baffled how what seems to be a critical fuse is a) missing b) seems to have no effect.

Current codes (other than Yellow Brake and ABS das lights include

3A no message from EGS control
82 signal,, CAN ASC/DSC
And still all four O2ís

I tried to reset the ABs code and the EGS code but the connection failed on both.

I will be replacing the alternator, the idl control valve ( was occasionally throwing a mechanical failure code) and the MAF sensor soon but frankly not optimistic.

Thanks for every opinion I get.


Sent from my iPad using Tapatalk
Reply With Quote
  #28  
Old 10-01-2021, 02:00 PM
Member
 
Join Date: Oct 2018
Location: Atlanta
Posts: 329
Oldmactech is on a distinguished road
Things Iíve learned.

Got into it to day and replaced the Idle Control Valve.
On reassemble I inspected the DISA valve and itís is broke. (I think). There is 100% slack on the flap so even if itís getting vacuum itís not functioning. Ran out of time but will troubleshoot tomorrow.


Sent from my iPad using Tapatalk
Reply With Quote
  #29  
Old 10-01-2021, 03:50 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 8,507
andrewwynn will become famous soon enough
Look at my repair thread on my wifeís failed I fixed it for $.18
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #30  
Old 10-03-2021, 08:14 PM
Member
 
Join Date: Oct 2018
Location: Atlanta
Posts: 329
Oldmactech is on a distinguished road
Failed DISa?


Sent from my iPad using Tapatalk
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 07:15 AM.
vBulletin, Copyright 2021, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.