Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-13-2011, 12:21 PM
CT_X5_Joe's Avatar
Member
 
Join Date: Dec 2010
Location: Connecticut
Posts: 158
CT_X5_Joe is on a distinguished road
Bluetooth and PDC problems

Hi all

Ok. First off, I love my new (new to me) X5. 2006, 17k miles now, drove it up to VT last weekend, took on 10+ inches of snow like nothing. Much better ride, and overall, quality compared to my old Mercedes ML 55.

Now for the gremlins...

Last night on my way to hockey my BLUETOOTH started acting funny. After I made a call it wouldn't turn off (meaning the music would not come back on) as the system said the phone was still on. I figured I would just turn off the car and back on to see if it fixed it. I did exactly that, and then one of my HEADLIGHTS (passenger side) low beam HID wouldn't come on. I reset that a few times via the switch and it started working, however the color of the bulb is now off (more blue tint) than the drivers side.

In addition to all this, my PDC system is going absolutely nuts. I first thought I might have snow or ice on the sensor, but I checked and they are all clear. The system is basically thinking I always have something 5" in front of me.

Also, the other item on my list is the car takes a bit to long to fire. It turns over for about 2-3 seconds and then fires off. (no funny sounds or anything, just takes a bit too long I think)

SO... I guess my question is does anyone have any advise? I plan on getting a new battery this weekend (going optima red top) as I am seeing the common issue here is electrical. Has this happened to anyone else on here? Was a new battery the fix??

Thanks
Reply With Quote

Sponsored Links

  #2  
Old 01-13-2011, 12:23 PM
CT_X5_Joe's Avatar
Member
 
Join Date: Dec 2010
Location: Connecticut
Posts: 158
CT_X5_Joe is on a distinguished road
I guess I should add that I live in CT and its very cold (about 20-30*) here right now, so that might be further taxing my battery. Having said this, I got the X5 back in mid December, when it was also cold, and haven't had a single problem until yesterday.
Reply With Quote
  #3  
Old 07-07-2012, 08:45 PM
TerminatorX5's Avatar
Member
 
Join Date: Jul 2006
Location: Stafford, VA & Harrisburg, PA - USA
Posts: 5,736
TerminatorX5 is on a distinguished road
did a new battery fix the issue?
__________________
E53 X5 4.6iS
147K mi - Sold May 2013
Tireprints left in:
USA, Nicaragua, Costa Rica, Panama, Russia

E53 X5 4.8iS built 2005-10-17
66200 mi - June 2012
96000 mi - June 2013
112000 mi - June 2014
OEM fire extinguisher
OE first aid kit
OE tow hitch
OE TV module
OE aspheric mirror
K&N air filter
black/white badges
rear camera
4-channel video recorder

Here is the list of things I have done to the X
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 09:22 PM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.