Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-28-2011, 01:04 AM
X5only's Avatar
Premier Member
 
Join Date: Feb 2008
Location: Bellevue, WA
Posts: 905
X5only is on a distinguished road
Electronic Brake-Force Distribution (EBV) fault

Electronic Brake-Force Distribution (EBV) fault
Hi,

On a 2005 X5 4.4 sports both DIS and INPA report diagnostic fault in Electronic Brake-Force Distribution (EBV). No warning lights show up in the dash, car performs fine as far as I can feel and there're no other fault codes stored. The EBV fault always come back after being cleared and driving the car for a while.

The interesting thing is that DIS reports that the fault is not relevant to the software version of the EBV control unit, but then recommends to continue troubleshooting in the running-gear control system. I could not find such a system in DIS to verify if this is indeed not really a fault.

Also interesting is that DIS always reports that the model series for which the instrument cluster was coded could not be identified and this can result in false readings. I've re-coded it via Progman but still get same report from DIS.

Now, does the EBV control unit need a software update? I tried to do that via Progman but no such control unit is listed for the car.

Appreciate any ideas on what exactly is the issue here if indeed their any. Or is this by design as probably indicated by the DIS report? Anyone with similar diagnostic report? I'm trying to avoid going to dealer who'll surely charge an arm and a leg for any daignostics verifications.

Thanks!
Attached Images
   
__________________
'05 E53 X5 4.4i, '97 E39 528, '07 E92 335i, '16 F86 X6M.

Last edited by X5only; 10-28-2011 at 01:10 AM. Reason: correction
Reply With Quote

Sponsored Links

  #2  
Old 10-28-2011, 02:14 PM
ECS Tuning's Avatar
Vendor
 
Join Date: Oct 2008
Location: Ohio
Posts: 1,399
ECS Tuning is on a distinguished road
After a bit of research it sounds like the system had a "hiccup". A code must occur 5 times in a cycle in order for the driver to be alerted. I'd clear the codes and make a mental note of the code. If i the future it comes back that is when I would further investigate.

ECS Tuning
Reply With Quote
  #3  
Old 10-30-2011, 01:03 AM
X5only's Avatar
Premier Member
 
Join Date: Feb 2008
Location: Bellevue, WA
Posts: 905
X5only is on a distinguished road
That's what I've been doing and it keeps coming back. However, no warning lights. Any one with INPA or DIS seeing anything similar with their X5?
__________________
'05 E53 X5 4.4i, '97 E39 528, '07 E92 335i, '16 F86 X6M.
Reply With Quote
  #4  
Old 10-30-2011, 12:12 PM
wilkoturbo's Avatar
Member
 
Join Date: Nov 2007
Location: england
Posts: 267
wilkoturbo is on a distinguished road
Yep same here I clear it every time
Reply With Quote
  #5  
Old 10-30-2011, 01:54 PM
X5only's Avatar
Premier Member
 
Join Date: Feb 2008
Location: Bellevue, WA
Posts: 905
X5only is on a distinguished road
Now that's interesting. Do you also get the DIS note that the model series for which the instrument cluster was coded couldn't be identified? I've recoded it to no avail- keeps coming back with the warning. Other than that warning everything's working perfectly.
__________________
'05 E53 X5 4.4i, '97 E39 528, '07 E92 335i, '16 F86 X6M.
Reply With Quote
  #6  
Old 05-29-2012, 02:55 PM
Member
 
Join Date: Oct 2011
Location: NYC
Posts: 4,588
SlickGT1 is on a distinguished road
I get the exact same thing. I keep clearing it, testing it, doing all that is possible with the DIS, and it shows up every damn time. Can't seem to figure out what this is. No errors on cluster either.
Reply With Quote
  #7  
Old 05-29-2012, 05:44 PM
Member
 
Join Date: Jan 2012
Location: New Zealand
Posts: 20
percodan is on a distinguished road
I get the same thing using BMW Scanner 1.4
Reply With Quote
  #8  
Old 01-03-2013, 08:26 AM
Member
 
Join Date: Jan 2012
Location: Sydney, Australia
Posts: 217
frozenwaffles is on a distinguished road
i have the same error too now. is the a EBV valve somewhere in our X5s?
has anyone done any suspension work recently before they were getting this error?
__________________
X5 2001 4.4i E53
Reply With Quote
  #9  
Old 01-03-2013, 08:37 AM
Member
 
Join Date: Oct 2011
Location: NYC
Posts: 4,588
SlickGT1 is on a distinguished road
No it seems like an e53 glitch. Every single person gets this when we connect DIS. We only connected it to 3 e53s, but everyone got it.
__________________
2006 4.8is, Black on White.

"The older we grow the greater becomes our wonder at how much ignorance one can contain without bursting one's clothes." - Mark Twain

Unlock OBC post 5
Reply With Quote
  #10  
Old 01-03-2013, 08:38 AM
Member
 
Join Date: Apr 2012
Location: Wenonah NJ
Posts: 333
sockethead is on a distinguished road
Haha Me too! Same error. I've been ingoring it for a year now... It would be nice if we can figure out what the heck it is...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 11:26 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.