Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E70) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-10-2023, 02:15 PM
jeep's Avatar
Member
 
Join Date: Jul 2008
Location: USA
Posts: 435
jeep is on a distinguished road
P030X errors misfires after plugs and coils replaced

So my daughter was driving the X5 couple of days back and the engine was not running smooth, lot of vibrations. Immediately thought of misfire and plugs needing replacement (have been procrastinating). Sure enough pulled the codes, there was a misfire on cylinder 4. So I replaced all the plugs (still had the originals NGK which were pretty worn out, but man did they last long) and the coils, all Bosch.

There was oil on the 4th plug, looks like Valve Cover gasket issue, have ordered it, but thinking should I replace with the Aluminum after market?

After replacing cold started the car, lots of vibrations, could smell gas as well, getting all kinds of random misfires across all the cylinders. Got an XDrive and DSC failure, limp mode. Have parked the car back.

What do you folks think is the issue here? Plugs and/or coils not installed properly?

Thanks
__________________
2008 E70 X5 3.0si
Sport | Prem | Adaptive Drive | Tech. | Cold Wthr | Rear Climate | 3rd Row | Running Boards | iPod/USB

2019 G30 530e
Sport | Adaptive | Drv. Assist+ | HK | HOV Access

2018 F83 M4
Comp. | Exec | DCT | First M Car

2009 E93 335i (Sold)
Sport | Prem | 19" 230 | Logic 7 | iPod/USB | Sat | HD Radio | Comfort Access | Heated Seats | Pure Joy

E36 328is GoKart (Sold)
Manual | HK | Trip Comp. | 17" Rims
Reply With Quote

Sponsored Links

  #2  
Old 05-10-2023, 02:25 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 10,731
andrewwynn will become famous soon enough
P030X errors misfires after plugs and coils replaced

Clear codes, set up hidden menu find the submenu with voltage and monitor real-time. When you start getting random error on multiple modules the first thing to check is stable voltage.

Do you have a BMW capable scanner so you can check the body modules. Usually if voltage fluctuation you'll get a handful of modules pissed off and will throw a low voltage code.

Also: if you do get a code on a particular cylinder swap coils with a different that's not a direct neighbor clear codes and try again. I think you said you got new coils but you could have gotten a defective one. New often ≠ fixed.
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)
Reply With Quote
  #3  
Old 05-10-2023, 02:33 PM
jeep's Avatar
Member
 
Join Date: Jul 2008
Location: USA
Posts: 435
jeep is on a distinguished road
Quote:
Originally Posted by andrewwynn View Post
Clear codes, set up hidden menu find the submenu with voltage and monitor real-time. When you start getting random error on multiple modules the first thing to check is stable voltage.

Do you have a BMW capable scanner so you can check the body modules. Usually if voltage fluctuation you'll get a handful of modules pissed off and will throw a low voltage code.

Also: if you do get a code on a particular cylinder swap coils with a different that's not a direct neighbor clear codes and try again. I think you said you got new coils but you could have gotten a defective one. New often ≠ fixed.
Battery was completely drained when I did the initial start, plugged in the battery charger/tender till it read about 95%. Started the car and got all those faults. I also noted that the gap on the new plugs is really small compared to the ones I pulled from the car, can that be an issue? New plugs have 1mm gap, almost 1.1mm. On youtube the guy recommended 1.1mm so I did not touch the plugs. Should I gap them more? Screwdriver method ok?
__________________
2008 E70 X5 3.0si
Sport | Prem | Adaptive Drive | Tech. | Cold Wthr | Rear Climate | 3rd Row | Running Boards | iPod/USB

2019 G30 530e
Sport | Adaptive | Drv. Assist+ | HK | HOV Access

2018 F83 M4
Comp. | Exec | DCT | First M Car

2009 E93 335i (Sold)
Sport | Prem | 19" 230 | Logic 7 | iPod/USB | Sat | HD Radio | Comfort Access | Heated Seats | Pure Joy

E36 328is GoKart (Sold)
Manual | HK | Trip Comp. | 17" Rims
Reply With Quote
  #4  
Old 05-10-2023, 02:36 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 10,731
andrewwynn will become famous soon enough
Get live voltage reading it should be 14.6 .3. Get car started and drive around the block after clearing codes. Did battery for from non use or was it a surprise?
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)
Reply With Quote
  #5  
Old 05-10-2023, 03:56 PM
jeep's Avatar
Member
 
Join Date: Jul 2008
Location: USA
Posts: 435
jeep is on a distinguished road
Quote:
Originally Posted by andrewwynn View Post
Get live voltage reading it should be 14.6 .3. Get car started and drive around the block after clearing codes. Did battery for from non use or was it a surprise?
Have had the battery problems for a while. Nowdays the car is not used as much as my daughter has been learning on it, and it did throw the high battery drain error few days back. I was planning to charge the battery nevertheless.

Yesterday when I tried driving the car it immediately went on limp mode and threw 4x4 and DSC malfunction errors on the screen. I was barely able to get it back into the garage. No chance of risking driving till I am able to resolve the cold start vibrations issue.

Was pulling out the new coils to put back the old ones to see if the errors dissapear, but looks like the new coils vacuum sealed on to the spark plugs, was very difficult to get them out, broke 2 of the latches in the process. Last one is still stuck all the way in the back. If it doesn't come out will replace the rest and try starting the engine. Might be easier to take it out on a slightly warm motor.
__________________
2008 E70 X5 3.0si
Sport | Prem | Adaptive Drive | Tech. | Cold Wthr | Rear Climate | 3rd Row | Running Boards | iPod/USB

2019 G30 530e
Sport | Adaptive | Drv. Assist+ | HK | HOV Access

2018 F83 M4
Comp. | Exec | DCT | First M Car

2009 E93 335i (Sold)
Sport | Prem | 19" 230 | Logic 7 | iPod/USB | Sat | HD Radio | Comfort Access | Heated Seats | Pure Joy

E36 328is GoKart (Sold)
Manual | HK | Trip Comp. | 17" Rims
Reply With Quote
  #6  
Old 05-11-2023, 12:28 AM
ard ard is offline
Member
 
Join Date: Mar 2006
Location: Sierra Foothills, California
Posts: 6,724
ard is on a distinguished road
What are your fuel trims??


Where did you get the plugs and coils from? are these EXACT oe replacements??? not 'better performance'? there are tons of counterfeits...and some of the higher performance plugs will NOT work. Yes they fit. Yes companies sell them...
Reply With Quote
  #7  
Old 05-11-2023, 12:42 AM
jeep's Avatar
Member
 
Join Date: Jul 2008
Location: USA
Posts: 435
jeep is on a distinguished road
Quote:
Originally Posted by ard View Post
What are your fuel trims??


Where did you get the plugs and coils from? are these EXACT oe replacements??? not 'better performance'? there are tons of counterfeits...and some of the higher performance plugs will NOT work. Yes they fit. Yes companies sell them...
Right on the money, Bosch coils and plugs, OE, seems the Coils are fake, even though got them from Amazon and they were supposed to be the right fit for the X5. I pulled all the coils installed the original ones, one of the originals was bad, one of the coils from Amazon worked have put that in for now, but will probably replace it.

I seem to catch the fake/defective ones often, same happened to one of the plugs I got from FCP for the M4, got replacements from Amazon which worked. But I still feel the car is not as smooth as with the original plugs. I checked the gaps and they were all correct measurements.
__________________
2008 E70 X5 3.0si
Sport | Prem | Adaptive Drive | Tech. | Cold Wthr | Rear Climate | 3rd Row | Running Boards | iPod/USB

2019 G30 530e
Sport | Adaptive | Drv. Assist+ | HK | HOV Access

2018 F83 M4
Comp. | Exec | DCT | First M Car

2009 E93 335i (Sold)
Sport | Prem | 19" 230 | Logic 7 | iPod/USB | Sat | HD Radio | Comfort Access | Heated Seats | Pure Joy

E36 328is GoKart (Sold)
Manual | HK | Trip Comp. | 17" Rims
Reply With Quote
  #8  
Old 05-11-2023, 10:18 AM
Member
 
Join Date: Aug 2016
Location: Detroit, MI
Posts: 302
Nanniepoo is on a distinguished road
Quote:
Originally Posted by jeep View Post
Have had the battery problems for a while. Nowdays the car is not used as much as my daughter has been learning on it, and it did throw the high battery drain error few days back. I was planning to charge the battery nevertheless.

Yesterday when I tried driving the car it immediately went on limp mode and threw 4x4 and DSC malfunction errors on the screen. I was barely able to get it back into the garage. No chance of risking driving till I am able to resolve the cold start vibrations issue.
You will get 4x4/DSC warnings for a low battery voltage. I would surmise that you're maybe conflating issues and it's possible some of the poor running could be bad battery/alternator too.
__________________
'08 X5 4.8i - 173k
'15 i3 - 76k

'98 323is - 169k - Garaged
'94 325i - 208k - Sold
Reply With Quote
  #9  
Old 05-11-2023, 10:47 AM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 10,731
andrewwynn will become famous soon enough
Still running like hell at start? Or did swap of coils help? Clears codes and what comes back


Sent from my iPhone using Tapatalk Pro
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)
Reply With Quote
  #10  
Old 05-11-2023, 02:44 PM
jeep's Avatar
Member
 
Join Date: Jul 2008
Location: USA
Posts: 435
jeep is on a distinguished road
Quote:
Originally Posted by andrewwynn View Post
Still running like hell at start? Or did swap of coils help? Clears codes and what comes back


Sent from my iPhone using Tapatalk Pro
Everything running fine now, cleared codes, no more errors, engine purring like a kitten, driving much better than before. Bad coils could have been draining the battery more as well, leading to the other issues. I will do some live monitoring to see voltage and fuel trim.

I did lose one of the engine cover bolts in there somewhere and found a cap like thing after putting back everything. Does the PCV valve have a plastic cap like thing on it?
__________________
2008 E70 X5 3.0si
Sport | Prem | Adaptive Drive | Tech. | Cold Wthr | Rear Climate | 3rd Row | Running Boards | iPod/USB

2019 G30 530e
Sport | Adaptive | Drv. Assist+ | HK | HOV Access

2018 F83 M4
Comp. | Exec | DCT | First M Car

2009 E93 335i (Sold)
Sport | Prem | 19" 230 | Logic 7 | iPod/USB | Sat | HD Radio | Comfort Access | Heated Seats | Pure Joy

E36 328is GoKart (Sold)
Manual | HK | Trip Comp. | 17" Rims
Reply With Quote
Reply

Bookmarks

Tags
ignition coils, p0300, p030x, spark plugs

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 01:34 PM.
vBulletin, Copyright 2024, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.