Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X6 (F16) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-05-2023, 10:33 PM
Member
 
Join Date: Mar 2016
Location: OC, CA
Posts: 23
mikeson is on a distinguished road
Wheel or brake noise

Hi guys.

I have this squeak noise. When I start it doesn't have noise. After drive while and wheel and brake become HOT, then after I stop, slowly move, I can hear this squeak noise.

Brake pad and rotors are new. I removed and reinstalled it but I still have this noise.
I think it is from front passenger side but I can't find what this is.

What do you think?
Thank you for you guys opinions.

Volume up and when I slowly move, you can hear the noise.

Reply With Quote

Sponsored Links

  #2  
Old 08-06-2023, 06:53 AM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 3,638
EODguy is on a distinguished road
Is that squeaking when lightly touching the brakes or without touching the brakes?

Most likely causes....

Without touching- Dirty glide pin keeping brake on lightly or loose/bent heat shield.

With touching- Grease on pads or rotor.


Sent from my SM-A528B using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote
  #3  
Old 08-06-2023, 08:43 AM
Member
 
Join Date: Mar 2016
Location: OC, CA
Posts: 23
mikeson is on a distinguished road
Without brake.
just release the brake pedal and slowly move I have this sound. But only after hard drive so brake is HOT condition.
Reply With Quote
  #4  
Old 08-06-2023, 08:57 AM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 3,638
EODguy is on a distinguished road
Quote:
Originally Posted by mikeson View Post
Without brake.
just release the brake pedal and slowly move I have this sound. But only after hard drive so brake is HOT condition.
Probably a glide pin issue. Did you grease the glide pins?

If you did it'll collect dust and dirt and may cause it to drag a little.

Sent from my SM-A528B using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote
  #5  
Old 08-07-2023, 04:59 PM
Member
 
Join Date: Mar 2016
Location: OC, CA
Posts: 23
mikeson is on a distinguished road
Thank you. I will replace the glide pin to new one and I will update you guys.
Reply With Quote
  #6  
Old 08-08-2023, 03:35 AM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 3,638
EODguy is on a distinguished road
Honestly I'd just use a green scrubby pad.

Sent from my SM-A528B using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote
  #7  
Old 08-19-2023, 01:15 PM
Member
 
Join Date: Mar 2016
Location: OC, CA
Posts: 23
mikeson is on a distinguished road
I replaced the pins but I still have the noise. I haven't had a chance to hard drive but I was able to hear it after freeway ride.
Reply With Quote
  #8  
Old 08-19-2023, 01:22 PM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 3,638
EODguy is on a distinguished road
Quote:
Originally Posted by mikeson View Post
I replaced the pins but I still have the noise. I haven't had a chance to hard drive but I was able to hear it after freeway ride.
And your dust shield is tight and not bent? Do you know if it is both sides or just one? Put the windows down and drive down a narrow alley/road that has concrete walls on both sides, forwards and backwards. If it does it in both directions it's probably not a pad issue. Did you see any glazing on the pads? Did you bed them in when you changed them?

Sent from my SM-A528B using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote
  #9  
Old 08-28-2023, 11:06 PM
Member
 
Join Date: Mar 2016
Location: OC, CA
Posts: 23
mikeson is on a distinguished road
It doesn't have noise when I reverse.
Only right after hard drive and hard brake,... then slowly move. when I push brake pedal lightly, noise is gone.
when I release my foot from brake pedal, noise come back.
And funny thing is next light, if I try to record with my cell phone, there is no noise.
hmm


And today, noise was louder when I try to make a right turn.(of course I pushed brake before turn) and noise is coming from passenger side for sure.
only one side.

It is hard to capture with my cell phone.
Right for example today, I drove about 15 minutes and was hot day. when I slow down at traffic, and slowly move, I heard the noise. When I try to capture it with my cell phone, there is no noise at all next 2 light stop. and after 4th light stop, there was noise, and I pull out my cell phone and try to capture but there is no noise at all.
But one thing sure is that I usually hear the noise right after when I push drive hard(go fast and strong stop, and go)and when I drive mild for while, there is no noise.

Last edited by mikeson; 08-28-2023 at 11:13 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 06:10 PM.
vBulletin, Copyright 2023, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.