Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Bluetooth
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-23-2007, 10:43 AM
Member
 
Join Date: May 2005
Location: X5world
Posts: 40
ChitownX5 is on a distinguished road
Unhappy Sony Ericsson K550i won’t sync or connect via Bluetooth

About a month ago I purchased a Sony Ericsson K550i (http://www.sonyericsson.com/spg.jsp?...=10745&zone=pp ). This is probably the best all-in-one phone for its price and size. The downsize being that it won’t sync or connect with my 2005 X5 with a March 2005 build date and the combined Bluetooth/Assist. The first time that I tried to sync the phone with the X it locked up the phone module. I had to disconnect the battery to reset the TCU. After multiple attempts and lock-ups, I took the X into my dealer for service. The technician upgraded the TCU software and afterwards was able to sync/connect multiple phones except the SE K550i of course. At least the TCU no longer locks-up. Occasionally the phone will connect and attempt to sync, but disconnects or will not reconnect the next time. I have tried just about every which way to connect the phone plus deleted all messages from the phone and tried switching between the SIM contacts and the phones contacts. SE support will take no responsibility and claims there is a known issue with the Johnson Controls Bluetooth module in Acura’s, Honda’s and BMW. I thought the BMW module was either Motorola or Visteon. Does anyone have any suggestions? If not I will be returning this phone for one that syncs.

Thx
Reply With Quote

Sponsored Links

  #2  
Old 05-23-2007, 11:49 AM
xx3's Avatar
xx3 xx3 is offline
Member
 
Join Date: Nov 2005
Location: California
Posts: 1,177
xx3 is on a distinguished road
Strange. My K800i & Z610i which are both very new SE phone's work perfectly...

I thought I would have to go back to one of my older SE handsets (I collect them... ) to get it to work with BMW bluetooth.

But maybe my module is 06' and thats why? Hmm... Anyone got any other idea's?
Reply With Quote
  #3  
Old 05-23-2007, 02:18 PM
Member
 
Join Date: May 2005
Location: X5world
Posts: 40
ChitownX5 is on a distinguished road
Quote:
Originally Posted by xx3
Strange. My K800i & Z610i which are both very new SE phone's work perfectly...

I thought I would have to go back to one of my older SE handsets (I collect them... ) to get it to work with BMW bluetooth.

But maybe my module is 06' and thats why? Hmm... Anyone got any other idea's?
Really? Did you have to do anything special to get these phones to work? Did your phone book come across?

I would really like to get this phone to work. It's so much better then anything offered by T-Mobile.
Reply With Quote
  #4  
Old 05-24-2007, 03:26 AM
Member
 
Join Date: Feb 2006
Location: Adelaide, Australia
Posts: 38
CortinaD is on a distinguished road
Quote:
Originally Posted by ChitownX5
Really? Did you have to do anything special to get these phones to work? Did your phone book come across?

I would really like to get this phone to work. It's so much better then anything offered by T-Mobile.
FWIW: I recently purcahsed a W880i SE and that pairs perfectly. While I was at the shop testing the phones I grabbed a W810i and that paired but wouldn't maintain it for more than a few seconds.
Reply With Quote
  #5  
Old 06-09-2007, 10:21 AM
jasonrhcastle's Avatar
Member
 
Join Date: Jun 2007
Location: Cincinnati, Ohio
Posts: 323
jasonrhcastle is on a distinguished road
I have had the k550i and now have the w610i. Both paired fine with my 07 530i with iDrive and NAV with no issue. I actually like it really well.

Hope it helps.

Jason
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 01:57 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.