Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Mobile Electronics Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-06-2016, 01:57 AM
Member
 
Join Date: Jul 2016
Location: Coral Springs, FL
Posts: 3
Slick92GSR is on a distinguished road
OEM radio issue -- Wife threatening...

New to X5 but not to BMW, able figure out that the 'radio' is a MID. searched for a bit.. i need help!

Just picked up this gorgeous Topaz Blue w/105000 miles for the wife
2001 3.0 X5.
3rd owner per carfax
Excellent condition
BUT RADIO not working.. wife says she's going back to a KIA if i don't get it fixed!!
  • unit has power because i can set the clock time & date,
    brightness dims with dash light control
    no radio sound or station information whatsoever
    in dash single Business CD under the cover
    its a 'high dash' because it has Tel control
    no NAV
    the cargo area has just the amp on the left
    no water in cargo area issues
    pulled and re-installed fuses 7, 72-73
    no little red fuse under the spare next to the battery
    no other components in the cargo area

seems prewired for other stuff, am i missing another component?
How do i check if the amp is blown?
can a blown amp cause this situation?
battery was dead when i first went to see the X5, could that be the issue?

all help appreciated..
thanks in advance

Last edited by Slick92GSR; 07-06-2016 at 01:58 AM. Reason: spelling
Reply With Quote

Sponsored Links

  #2  
Old 07-07-2016, 01:51 AM
Member
 
Join Date: Jul 2016
Location: Coral Springs, FL
Posts: 3
Slick92GSR is on a distinguished road
Can anyone take a picture of their amp setup in the cargo area ?
Reply With Quote
  #3  
Old 07-08-2016, 03:59 PM
wpoll's Avatar
Member
 
Join Date: Sep 2015
Location: South Island, New Zealand
Posts: 3,023
wpoll will become famous soon enough
Does the CD player produce sound, i.e. is the amp actually working?
__________________
Wayne
2005 BMW X5 3.0d (b 02/05)
2001 BMW F650GS Dakar (b 06/01)
Reply With Quote
  #4  
Old 07-11-2016, 07:25 AM
Member
 
Join Date: Jul 2016
Location: Coral Springs, FL
Posts: 3
Slick92GSR is on a distinguished road
This weekend, I was able to swap the amp into my e46 Touring and the system functioned fine. I also removed the MID and the Business CD from the dash to check connections. The B-CD does not have any visual sign of life, although when I remove and re-install the fuse at the back, it makes a quick CD-loading noise. Still stumped..
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 11:56 AM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.