Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Navigation System
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-17-2009, 01:41 PM
Member
 
Join Date: Nov 2009
Location: Austria
Posts: 13
Austrijanac is on a distinguished road
Bmw 530dA Navigation System and Battery Drain

I have a problems with my 5-er few weeks now .When I live auto few days without start my batery drein out.I Found A Solution for that...take out a fuse for audio end navigation end then my battery stay intact.Im notice that my navigation screen have some strange blue color end font....On the Menu dont see anymore Navigation option.Im notice that navigation cd try to load disc few times end than disc get out....than get in again end that stops when I take fuse out.On the navigation screen (uper right corner)I dont see SW Number anymore!
I dont now what to do....tray to upgrade navigation sw (maybe this solve the problem)or take car to Bmw dealer?
Any suggestion is welcomed.Thanks in advance......
PS.Bmw 530dA 2001 MkIII Navigation
Reply With Quote

Sponsored Links

  #2  
Old 11-17-2009, 02:03 PM
Weasel's Avatar
Almost never on here anymore :(
 
Join Date: Jul 2008
Location: New Orleans, La
Posts: 6,892
Weasel will become famous soon enough
Sometimes the NAV computers just crap out and cause battery drain as a result. Unfortunately it usually required NAV computer replacement. Maybe a good time to upgrade to a newer DVD NAV system.
__________________
"When you do things right, people won't be sure you've done anything at all" (Bender, futurama)

You make something idiotproof, they'll make a better idiot


You think professional is expensive, just wait until you pay for amateur.

Never let your sense of morals prevent you from doing what is right.

Examine what is said, not who speaks.

X5 pics

RIP 4.6is.....

2003 4.6is
Reply With Quote
  #3  
Old 11-17-2009, 03:13 PM
Member
 
Join Date: Dec 2006
Location: Switzerland
Posts: 2,575
KiwiJochen is on a distinguished road
classic symptoms of water damage in the power circuitry of the nav
Reply With Quote
  #4  
Old 11-17-2009, 04:05 PM
Member
 
Join Date: Nov 2009
Location: Austria
Posts: 13
Austrijanac is on a distinguished road
Quote:
Originally Posted by KiwiJochen View Post
classic symptoms of water damage in the power circuitry of the nav
Kiwi can you please explane a little bit closer end how to fix this?
Thanks
Reply With Quote
  #5  
Old 11-17-2009, 04:34 PM
Member
 
Join Date: Dec 2006
Location: Switzerland
Posts: 2,575
KiwiJochen is on a distinguished road
Quote:
Originally Posted by Austrijanac View Post
Kiwi can you please explane a little bit closer end how to fix this?
Thanks
Open the nav and remove the main circuit board
Observe the bottom rear corners of the board
Note the corrosion caused by water damage
Repair as required (requires specialised skills)

Note: you may also simply have a failled power circuit.
Reply With Quote
  #6  
Old 11-17-2009, 05:09 PM
Member
 
Join Date: Nov 2009
Location: Austria
Posts: 13
Austrijanac is on a distinguished road
Thank you Kiwi!Failled power circuit is more possibil.....I will check tomorrow......By The Way maybe someone now where to find last os upgrade (custom splash screen )with mode2/step 1 end cd key.I will tray to upgrade one way or another.........
Reply With Quote
  #7  
Old 11-24-2009, 03:35 PM
Member
 
Join Date: Nov 2009
Location: Austria
Posts: 13
Austrijanac is on a distinguished road
Hi Everyone
I try everything.No water damage,no failled power circuit.Drive my car to independent mehanic.He said that my nav computer is death.He sad when red power led dosen't turn on that is single end first sign that my nav computer is death.He suggest replacement.
I read somewhere when nav comeputer is real death red led is off,cd eject funktion inoperativ end no sound from audio system end screen is pernanetly black.I have only red power led off... everything else work!!!I dont now what to do.......
Any suggestion?
Reply With Quote
  #8  
Old 11-24-2009, 03:48 PM
Member
 
Join Date: Dec 2006
Location: Switzerland
Posts: 2,575
KiwiJochen is on a distinguished road
Sounds to me like the power supply in the nav has failled.

What made you reach the conclusion of "no failled power circuit" ?

All your symptoms point to failled power supply inside the nav...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 10:23 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.