Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Navigation System
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-12-2011, 03:04 AM
Member
 
Join Date: Aug 2011
Location: Athol, MA
Posts: 4
JackFunOne is on a distinguished road
Nav Screen Blank White...Requesting any Experience or Insights

Hello, I'm Jack, a new to me owner of a beautiful 2001 black on black 540i/6 Sport. Man, I love this car. I will love it more if I can figure fix the bright white screen. I have searched and read for three days. I've tried most if not all of the tired and tested DIY fix jobs. No joy, though. So, as a last hope, I thought I'd send out and SOS.

OK, here the case:
Prior Owners told me that the NAV (MK III) unit sometimes works and sometimes does not. I'm in day 5 of ownership. Almost always stays blank white. Occasionally the screen will go black. When I open the door and turn on the key, it lights up bright white. Then, it occasionally go black with a few vertical lines, then, go back to blank white. Very irritating at night.
1. Radio always works..
2. I have tired the reset fix, no joy.
3. The Nav unit in the trunk has a red LED light on when I start the car, then goes out..
4. When I insert a map disk, it accepts it, spins, still blank white screen.
5. Downloaded very 32 and prior version. Inserted the disk. The Nav unit accepts it, spins for a few seconds, then spits it out?? Anyone know why?
6. I posted this issue on BimmerForoum, response is that Nav unit is faulty.
7. I have a line on a MK III for 3 bills, BUT, I do not know if the issue is the Nav Unit or the display screen???? Or is it software? Or is it a wiring issue. The blank white display goes black with a few vertical lines when I go over bumps. Anyone know how difficult it would be to get to all the wires from the trunk to the Dash Display?

If anyone has had the same problem, please hook me up. I know time is valuable. If you anyone can help me get to a successful conclusion, I'll gladly compensate you for helping me. I'm truly mad dog desperate. I know it would be easier to just go out and buy the MK V and new screen, but I am not prepared to go there yet. Front end is clunking over slow bumps so I think I have to prioritize some cash for the common linkage issue or ball joints or whatever is causing the slow speed clunking.

Anyways, please chime in here if you have any ideas whatsoever.

Appreciatively,
Jack
978/340-4600
Reply With Quote

Sponsored Links

  #2  
Old 08-14-2011, 09:03 PM
Brian-bmw's Avatar
Member
 
Join Date: Aug 2005
Location: Peachtee Corners, GA
Posts: 1,192
Brian-bmw is on a distinguished road
Those symptoms sound like a bad nav computer.
__________________
SOLD
2000 E38 750iL Highline Edition, Upgraded with the lastest 2006 X5 Electronics
MKIV Navigation, 16:9 Display, Bluetooth, TV/Video with Backup Camera, Sirius, and Aux Input
Reply With Quote
  #3  
Old 08-14-2011, 09:57 PM
Member
 
Join Date: Aug 2011
Location: Athol, MA
Posts: 4
JackFunOne is on a distinguished road
yes it does

Quote:
Originally Posted by Brian-bmw View Post
Those symptoms sound like a bad nav computer.

Thanks for responding. Yes, and by the way, I have read a lot of your writing on this topic. Thanks for sharing your experience and insights.

Yes, it seems that the Nav Unit is bad. My plan is to buy an MK IV. And, it is my hope that the unit will plug and play without any need for software or firmware or reseting procedures. And I guess we can hope...

I'm update as I go...just in case anyone else runs into this fairly common issue.
by the way, my dealer quoted me 2,800 out the door. That as kind of staggering.

Jack
Reply With Quote
  #4  
Old 08-15-2011, 05:40 AM
Member
 
Join Date: Feb 2006
Location: Switzerland
Posts: 67
Didi is on a distinguished road
Is your car equipped with a TV module? If yes this module may also cause the problem.

Btw. the exchange of the nav computer (MK3 -> MK 4) is just plug and play.
Don't you know anybody around you who may borrow you an other nav computer? Just to check wheather it's really the computer and nothing else...
__________________
330Ci convertible
Z1 roadster
Reply With Quote
  #5  
Old 08-15-2011, 07:28 AM
X5V8RULES's Avatar
Member
 
Join Date: Jun 2011
Location: FRANCE
Posts: 153
X5V8RULES is on a distinguished road
Nav computer problem ! When my nav comp was bad the screen was sometime black sometime white and there were weird lines
Reply With Quote
  #6  
Old 08-15-2011, 09:38 AM
Member
 
Join Date: Aug 2011
Location: Athol, MA
Posts: 4
JackFunOne is on a distinguished road
Quote:
Originally Posted by Didi View Post
Is your car equipped with a TV module? If yes this module may also cause the problem.

Btw. the exchange of the nav computer (MK3 -> MK 4) is just plug and play.
Don't you know anybody around you who may borrow you an other nav computer? Just to check wheather it's really the computer and nothing else...
Don't know if I have the TV module. I only know that my 01 has the 16: 9 screen with the MK III in the trunk. My logic is that I need to upgrade to the MK IV or Dynavin because I may need to jump start the car someday. Why would someone repair or replace when we know the problem will reoccur?

Perhaps this the reason why the market for used MK IV are at such a high premium...
Reply With Quote
  #7  
Old 08-15-2011, 09:43 AM
Member
 
Join Date: Aug 2011
Location: Athol, MA
Posts: 4
JackFunOne is on a distinguished road
Thank You

Quote:
Originally Posted by X5V8RULES View Post
Nav computer problem ! When my nav comp was bad the screen was sometime black sometime white and there were weird lines
Thanks X5V8RULES, for some reason I needed to hear that someone else has the exact same issue. I hope to "copy cat " your successful fix with a plug and play MK IV.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 04:40 PM.
vBulletin, Copyright 2018, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.