Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E53) Forum (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/)
-   -   Suspension help please (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/109858-suspension-help-please.html)

Madwelshman 02-22-2019 09:24 AM

Suspension help please
 
I have all round air suspension, and fitted a replacement head and seal on the pump the other day, now getting over 15 bar pressure.
The problem is the back end is low front end looks high and the system will not 0ut air in the back or operate on the raise lower controls.

Does anyone have any ideas as to the problem, no faults showing on the display so I am wondering if the EHC2 module is faulty or should I be looking elsewhere.

Need my car to get to work over 30 miles so canít use a taxi, getting to the point of having to buy a runaround if I canít sort it.

Any help would be appreciated

Thanks

amancuso 02-22-2019 10:29 AM

When mine did that, I had Inactive error message and the problem was two fold. Compressor was dodgy causing one of the very large fuses to pop. After replacing compressor and fuse, Indy reset the system and all was well.

Madwelshman 02-22-2019 10:34 AM

I have replaced the head and seal so pump is working good, was yours all round suspension or just rear, the reason I ask is the systems are totally different, fuse position and module type


All times are GMT -4. The time now is 05:18 PM.

vBulletin, Copyright 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved.