Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E53) Forum (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/)
-   -   A/C problem - help needed. (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/87325-c-problem-help-needed.html)

rocksteadyX5 05-14-2012 09:14 PM

Got my OEM FSR today in the mail...will replay it again this weekend - Hope it works. "Hot-lanta" is no joke in the summer.

rocksteadyX5 05-20-2012 03:21 PM

Just a follow yup.....it was tha FSR....the OEM did the trick....now it's nice and cold......that's all!!!!!!

TwinsPoppa 05-20-2012 11:37 PM

Quote:

Originally Posted by rocksteadyX5 (Post 878766)
Just a follow yup.....it was tha FSR....the OEM did the trick....now it's nice and cold......that's all!!!!!!

Wow. I hope that doesn't mean you have to replace the FSR every year.

rocksteadyX5 05-20-2012 11:39 PM

Quote:

Originally Posted by TwinsPoppa (Post 878814)
Wow. I hope that doesn't mean you have to replace the FSR every year.

I confess.... I didn't use an OEM the first time.....this time I did, let's hope I don't have to do this again.

Carrerax 05-24-2012 06:53 AM

Sorry to hijack but I am having a similar problem. Mine is a 2001 X5 4.4. I have had it for 7 years and on the original FSR. Anyway, yesterday driving home the AC was working great then it sounded like the fan slowed way down and wasnt blowing hard. I could turn the fan all the way up and it would blow harder but air wasnt blowing out much. I could feel that what was blowing out was cold though. This morning driving to work it was the same. Does this sound like I need a FSR? Thanks!!

rocksteadyX5 05-24-2012 08:35 PM

Quote:

Originally Posted by Carrerax (Post 879286)
Sorry to hijack but I am having a similar problem. Mine is a 2001 X5 4.4. I have had it for 7 years and on the original FSR. Anyway, yesterday driving home the AC was working great then it sounded like the fan slowed way down and wasnt blowing hard. I could turn the fan all the way up and it would blow harder but air wasnt blowing out much. I could feel that what was blowing out was cold though. This morning driving to work it was the same. Does this sound like I need a FSR? Thanks!!

If you check around the site you will see that the symptoms of the FSR bad or going bad vary. It is the cheapest thing to replace/do yourself. I would suggest try that first. Get an OEM FSR. ;-)

Instructions below. You can also check on Ebay for an OEM FSR.

http://www.xoutpost.com/articles/x5/...placement.html

hunds02 07-02-2012 11:18 AM

Sorry to revive this thread once again, but I was hoping I can get some help on diagnosing my AC problem. I have a similar problem to what most X5 drivers have, cold air for the driver and warm air in the center and right vents.

I know my FSR is bad because I can recall many times in the past where my aux fan will stay on after I turn the car off. So I ordered a new FSR (OEM BMW) last night and will plan to change it for the first time in this car. But now I realize that my aux fan never goes on anymore (within the past two or three days). So my question is, is there any chance a new FSR can get the fan to run again? It seems as the fan is dead rather than running erratically.

I also checked the r134a pressure on the low pressure port and it was about 45 psi which is high, I assume its because the aux fan was off which caused the pressure to rise. I have been keeping my AC off now since its over 100 F and I don't want to create more problems.

Weasel, hopefully you can chime in on this if you have any suggestions. Any other help will be greatly appreciated. I will post again after I get my new FSR.

SlickGT1 07-02-2012 11:32 AM

Put in the new FSR, then go use your AC. If there is charge, it will work, even if low, but not too low. So you will be ok to try it out. Then go to AC shop and get it recharged, and oiled.

hunds02 07-02-2012 11:35 AM

Thanks for your reply, I really hope that is the case and not the aux fan. It does not turn on at all anymore, so I may have to replace it if the FSR does not 'revive' it.

SlickGT1 07-02-2012 11:38 AM

Quote:

Originally Posted by hunds02 (Post 884116)
Thanks for your reply, I really hope that is the case and not the aux fan. It does not turn on at all anymore, so I may have to replace it if the FSR does not 'revive' it.

Is the aux fan, the AC fan on your car? I really don't know as I have an electric fan only. If it is the AC fan, it might not turn on due to low refrigerant, and oil.


All times are GMT -4. The time now is 08:43 PM.

vBulletin, Copyright 2023, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.